summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2018-09-12 14:07:19 +0200
committerSimon Brulhart2018-09-12 14:07:19 +0200
commite0e5c03680d8a77bc1521f6405dd91b1c75124f1 (patch)
treec4d8c3de50a17d80db6160c99faef363cbe13fc8
downloadaur-e0e5c03680d8a77bc1521f6405dd91b1c75124f1.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b3750ec655b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-taxi-zebra
+ pkgdesc = Zebra backend for Taxi
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/sephii/taxi-zebra
+ arch = any
+ license = custom
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-six
+ source = python-taxi-zebra-1.3.0.tar.gz::https://github.com/sephii/taxi-zebra/archive/1.3.0.tar.gz
+ source = https://raw.githubusercontent.com/sephii/taxi/master/LICENSE
+ sha512sums = 9c44e89cae3107605aa5b59faceb74a94607226b811c4ba882f555254a16d8240e058d881f23e0e941a5ff36a822d53eb8627a40ff2a60dd5accd3ce8542e431
+ sha512sums = 87e4e0e9f65b92db1a3f84823427b0870ae01675fa6e631a8c2e2d89eb12ee19d6011b4f4e74f6d4ca30868010206ef0ddd0b24a814c24b84bc41a5e68864dd4
+
+pkgname = python-taxi-zebra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..083df2a87a92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Simon Brulhart <simon@brulhart.me>
+
+pkgname='python-taxi-zebra'
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Zebra backend for Taxi"
+arch=('any')
+license=('custom')
+url="https://github.com/sephii/taxi-zebra"
+depends=('python-requests' 'python-six')
+makedepends=('python' 'python-setuptools')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/sephii/taxi-zebra/archive/$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/sephii/taxi/master/LICENSE"
+)
+sha512sums=('9c44e89cae3107605aa5b59faceb74a94607226b811c4ba882f555254a16d8240e058d881f23e0e941a5ff36a822d53eb8627a40ff2a60dd5accd3ce8542e431'
+ '87e4e0e9f65b92db1a3f84823427b0870ae01675fa6e631a8c2e2d89eb12ee19d6011b4f4e74f6d4ca30868010206ef0ddd0b24a814c24b84bc41a5e68864dd4')
+
+build() {
+ cd "$srcdir/taxi-zebra-$pkgver"
+ python setup.py build
+}
+
+package() {
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir/taxi-zebra-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}