summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-12-26 13:39:08 +0100
committerPhilipp A2019-12-26 13:39:08 +0100
commit650921a6c45d95321187f1bd9acc7e2372c931ab (patch)
treee1634386b6251a09f2e5a8428d7bde7829513d26
parent1721480713a7c4a92c006cc168f79386e2cf8703 (diff)
downloadaur-650921a6c45d95321187f1bd9acc7e2372c931ab.tar.gz
v0.3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c52e3f84892..bdfd4d6d17ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,15 @@
pkgbase = python-tbvaccine
pkgdesc = Pretty-print Python tracebacks
- pkgver = 0.2.2
+ pkgver = 0.3.1
pkgrel = 1
+ url = https://github.com/skorokithakis/tbvaccine
arch = any
license = MIT
- source = tbvaccine-0.2.2-py3-none-any.whl::https://pypi.python.org/packages/ad/68/af2fdc13122bde84e81af1b306915bcacf6eafb7b1be0f4466615f6dfc74/tbvaccine-0.2.2-py2-none-any.whl
- md5sums = 8fa534864c71636ca516e3956803c14b
+ makedepends = install-wheel-scripts
+ depends = python
+ noextract = tbvaccine-0.3.1-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/3.6/t/tbvaccine/tbvaccine-0.3.1-py2.py3-none-any.whl
+ sha256sums = 3aae41b75e237f2840dde274722b1070ca43d65dd24cf60344bd6d345c77cc3d
pkgname = python-tbvaccine
diff --git a/PKGBUILD b/PKGBUILD
index 8fb03d360c82..9025f2a3bcb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Phil Schaf <flying-sheep@web.de>
+# Maintainer: Philipp A. <flying-sheep@web.de>
-pkgname=python-tbvaccine
_name=tbvaccine
-pkgver=0.2.2
+pkgname=python-$_name
+pkgver=0.3.1
pkgrel=1
pkgdesc='Pretty-print Python tracebacks'
arch=(any)
-url=''
+url="https://github.com/skorokithakis/$_name"
license=(MIT)
-depends=()
-_wheel2="$_name-$pkgver-py2-none-any.whl"
-_wheel3="$_name-$pkgver-py3-none-any.whl"
-source=("$_wheel3::https://pypi.python.org/packages/ad/68/af2fdc13122bde84e81af1b306915bcacf6eafb7b1be0f4466615f6dfc74/$_wheel2")
-md5sums=('8fa534864c71636ca516e3956803c14b')
+depends=(python)
+makedepends=(install-wheel-scripts)
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/3.6/${_name::1}/$_name/$_wheel")
+sha256sums=('3aae41b75e237f2840dde274722b1070ca43d65dd24cf60344bd6d345c77cc3d')
noextract=("$_wheel")
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel3"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
}