summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-02-19 16:20:49 +0100
committerPhilipp A2022-02-19 16:20:49 +0100
commite639f3bf6c5e9461d933d2f4a0d219d2f8df9b0c (patch)
treebf2cfe4001e205b06e26ea6b3e662e1ac3f803aa
parent650921a6c45d95321187f1bd9acc7e2372c931ab (diff)
downloadaur-e639f3bf6c5e9461d933d2f4a0d219d2f8df9b0c.tar.gz
build from source
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdfd4d6d17ff..de3ae5d8342b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,11 +5,10 @@ pkgbase = python-tbvaccine
url = https://github.com/skorokithakis/tbvaccine
arch = any
license = MIT
- makedepends = install-wheel-scripts
+ makedepends = python-build
+ makedepends = python-installer
depends = python
- noextract = tbvaccine-0.3.1-py2.py3-none-any.whl
- source = https://files.pythonhosted.org/packages/3.6/t/tbvaccine/tbvaccine-0.3.1-py2.py3-none-any.whl
- sha256sums = 3aae41b75e237f2840dde274722b1070ca43d65dd24cf60344bd6d345c77cc3d
+ source = https://files.pythonhosted.org/packages/source/t/tbvaccine/tbvaccine-0.3.1.tar.gz
+ sha256sums = 8665d037ac8ad4c97bc44512de91798565b1226f7b2f59669bb7dbe9a1f87718
pkgname = python-tbvaccine
-
diff --git a/.gitignore b/.gitignore
index 3dd78fea8ca9..6ba567a70eb6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/pkg/
/src/
-/*.whl
-/*.pkg.tar.xz
+/*.tar.gz
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 9025f2a3bcb1..8809e39e76a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,16 @@ arch=(any)
url="https://github.com/skorokithakis/$_name"
license=(MIT)
depends=(python)
-makedepends=(install-wheel-scripts)
-_pyarch=py2.py3
-_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
-source=("https://files.pythonhosted.org/packages/3.6/${_name::1}/$_name/$_wheel")
-sha256sums=('3aae41b75e237f2840dde274722b1070ca43d65dd24cf60344bd6d345c77cc3d')
-noextract=("$_wheel")
+makedepends=(python-build python-installer)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('8665d037ac8ad4c97bc44512de91798565b1226f7b2f59669bb7dbe9a1f87718')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
- install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}