summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfl0w12017-09-01 14:01:39 +0200
committerfl0w12017-09-01 14:01:39 +0200
commitbd834f306534815f129f9916c0053a31c9893c60 (patch)
treeb912856e198dd86d107efa90b36cd418ea0fa469
downloadaur-bd834f306534815f129f9916c0053a31c9893c60.tar.gz
Initial PKGBUILD for python-tcconfig
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD25
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69a16e399758
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-tcconfig
+ pkgdesc = A Simple tc command wrapper tool. Easy to set up traffic control of network bandwidth/latency/packet loss/packet-corruption to a network interface.
+ pkgver = 0.14.1
+ pkgrel = 1
+ url = https://github.com/thombashi/tcconfig
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = iproute2
+ depends = python-dataproperty>=0.25.6
+ depends = python-simplesqlite>=0.15.0
+ depends = python-subprocrunner>=0.8.7
+ depends = python-typepy>=0.0.20
+ depends = python-voluptuous
+ depends =
+ depends = python-ipaddress
+ depends = python-logbook
+ depends = python-pyparsing>=2.2.0
+ depends = python-six
+ source = https://github.com/thombashi/tcconfig/archive/v0.14.1.tar.gz
+ md5sums = bebe8b2b9d76ffd3a39a837c30e10d6b
+
+pkgname = python-tcconfig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53a6595900dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer: Florian Wittmann <fl0w1@disroot.org>
+pkgname='python-tcconfig'
+_module='tcconfig'
+pkgver='0.14.1'
+pkgrel=1
+pkgdesc="A Simple tc command wrapper tool. Easy to set up traffic control of network bandwidth/latency/packet loss/packet-corruption to a network interface."
+url="https://github.com/thombashi/tcconfig"
+depends=('python' 'iproute2' 'python-dataproperty>=0.25.6' 'python-simplesqlite>=0.15.0' 'python-subprocrunner>=0.8.7' 'python-typepy>=0.0.20' 'python-voluptuous' \
+ 'python-ipaddress' 'python-logbook' 'python-pyparsing>=2.2.0' 'python-six')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://github.com/thombashi/tcconfig/archive/v${pkgver}.tar.gz")
+md5sums=('bebe8b2b9d76ffd3a39a837c30e10d6b')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/python-tcconfig/LICENSE"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}