summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-05 19:54:01 -0600
committerLuis Martinez2022-02-05 19:54:01 -0600
commit180e01f9ff8435e5b924034c83465011ecd3953d (patch)
treefea0e0e4bc6883926afc0c76d891a4bf9faeb39e
parentea8893a81b6ca0f0bdb1b912dcd41558be0af0de (diff)
downloadaur-180e01f9ff8435e5b924034c83465011ecd3953d.tar.gz
update to 13.4.0
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md10
-rw-r--r--PKGBUILD19
3 files changed, 25 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa944480e8aa..664faaed2147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tcod
pkgdesc = High-performance Python port of libtcod
- pkgver = 13.3.0
+ pkgver = 13.4.0
pkgrel = 1
url = https://github.com/libtcod/python-tcod
changelog = CHANGELOG.md
@@ -8,14 +8,18 @@ pkgbase = python-tcod
license = BSD
makedepends = git
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-install
+ makedepends = python-wheel
makedepends = python-pytest-runner
makedepends = python-pycparser
+ makedepends = python-pcpp
makedepends = python-sphinx
depends = python-cffi
depends = python-numpy
depends = python-typing_extensions
depends = sdl2
- source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.3.0?signed
+ source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.4.0?signed
source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed
validpgpkeys = 9EF1E80F3817BC043097A7C15814977902B194CC
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 8ba44236ad74..1bff981d04b5 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,16 @@ This project adheres to [Semantic Versioning](https://semver.org/) since version
## [Unreleased]
+## [13.4.0] - 2022-02-04
+### Added
+- Adds `sdl_window` and `sdl_renderer` to tcod contexts.
+- Adds `tcod.event.add_watch` and `tcod.event.remove_watch` to handle SDL events via callback.
+- Adds the `tcod.sdl.video` module to handle SDL windows.
+- Adds the `tcod.sdl.render` module to handle SDL renderers.
+- Adds the `tcod.render` module which gives more control over the rendering of consoles and tilesets.
+### Fixed
+- Fixed handling of non-Path PathLike parameters and filepath encodings.
+
## [13.3.0] - 2022-01-07
### Added
- New experimental renderer `tcod.context.RENDERER_XTERM`.
diff --git a/PKGBUILD b/PKGBUILD
index af9852820dbe..ba1b78a56a31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.3.0
+pkgver=13.4.0
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
@@ -13,14 +13,12 @@ url='https://github.com/libtcod/python-tcod'
license=('BSD')
depends=('python-cffi' 'python-numpy' 'python-typing_extensions' 'sdl2')
makedepends=(
- 'git'
- 'python-setuptools'
- 'python-pytest-runner'
- 'python-pycparser'
- 'python-sphinx')
+ 'git' 'python-setuptools' 'python-build' 'python-install' 'python-wheel'
+ 'python-pytest-runner' 'python-pycparser' 'python-pcpp' 'python-sphinx')
changelog=CHANGELOG.md
-source=("$pkgname::git+$url#tag=$pkgver?signed"
- 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed')
+source=(
+ "$pkgname::git+$url#tag=$pkgver?signed"
+ 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed')
sha256sums=('SKIP'
'SKIP')
validpgpkeys=('9EF1E80F3817BC043097A7C15814977902B194CC') # Kyle Benesch @ GitHub
@@ -34,7 +32,7 @@ prepare() {
build() {
cd "$pkgname"
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
cd docs
make man
}
@@ -46,8 +44,9 @@ build() {
# }
package() {
+ export PYTHONHASHSEED=0
cd "$pkgname"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 docs/_build/man/python-tcod.1 -t "$pkgdir/usr/share/man/man1/"
}