summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-13 12:24:36 -0600
committerLuis Martinez2022-02-13 12:24:36 -0600
commit359e653be88b38af7d07bc571d290b5fb7641a1e (patch)
treeb556448413a0ef249d59380775eb559e2c9a7835
parent180e01f9ff8435e5b924034c83465011ecd3953d (diff)
downloadaur-359e653be88b38af7d07bc571d290b5fb7641a1e.tar.gz
update to 13.5.0
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG.md13
-rw-r--r--PKGBUILD2
3 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 664faaed2147..cb90aa90ec46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tcod
pkgdesc = High-performance Python port of libtcod
- pkgver = 13.4.0
+ pkgver = 13.5.0
pkgrel = 1
url = https://github.com/libtcod/python-tcod
changelog = CHANGELOG.md
@@ -19,7 +19,7 @@ pkgbase = python-tcod
depends = python-numpy
depends = python-typing_extensions
depends = sdl2
- source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.4.0?signed
+ source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.5.0?signed
source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed
validpgpkeys = 9EF1E80F3817BC043097A7C15814977902B194CC
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 1bff981d04b5..b05c84596b17 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,9 +5,20 @@ This project adheres to [Semantic Versioning](https://semver.org/) since version
## [Unreleased]
+## [13.5.0] - 2022-02-11
+### Added
+- `tcod.sdl.audio`, a new module exposing SDL audio devices. This does not include an audio mixer yet.
+- `tcod.sdl.mouse`, for SDL mouse and cursor handing.
+- `Context.sdl_atlas`, which provides the relevant `SDLTilesetAtlas` when one is being used by the context.
+- Several missing features were added to `tcod.sdl.render`.
+- `Window.mouse_rect` added to SDL windows to set the mouse confinement area.
+### Changed
+- `Texture.access` and `Texture.blend_mode` properties now return enum instances.
+ You can still set `blend_mode` with `int` but Mypy will complain.
+
## [13.4.0] - 2022-02-04
### Added
-- Adds `sdl_window` and `sdl_renderer` to tcod contexts.
+- Adds `sdl_window` and `sdl_renderer` properties to tcod contexts.
- Adds `tcod.event.add_watch` and `tcod.event.remove_watch` to handle SDL events via callback.
- Adds the `tcod.sdl.video` module to handle SDL windows.
- Adds the `tcod.sdl.render` module to handle SDL renderers.
diff --git a/PKGBUILD b/PKGBUILD
index ba1b78a56a31..62d823a72583 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.4.0
+pkgver=13.5.0
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')