summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-19 11:14:28 -0600
committerLuis Martinez2022-02-19 11:14:28 -0600
commitb724ba5fe80e2c7c249ce92f086f1aa2d8d537f8 (patch)
tree9b869ed01d13f5eff08716b3cbcb0ae006e806f7
parent359e653be88b38af7d07bc571d290b5fb7641a1e (diff)
downloadaur-b724ba5fe80e2c7c249ce92f086f1aa2d8d537f8.tar.gz
update to 13.6.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md6
-rw-r--r--PKGBUILD6
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb90aa90ec46..6f7d05ecb451 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tcod
pkgdesc = High-performance Python port of libtcod
- pkgver = 13.5.0
+ pkgver = 13.6.0
pkgrel = 1
url = https://github.com/libtcod/python-tcod
changelog = CHANGELOG.md
@@ -9,7 +9,7 @@ pkgbase = python-tcod
makedepends = git
makedepends = python-setuptools
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-wheel
makedepends = python-pytest-runner
makedepends = python-pycparser
@@ -19,7 +19,7 @@ pkgbase = python-tcod
depends = python-numpy
depends = python-typing_extensions
depends = sdl2
- source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.5.0?signed
+ source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.6.0?signed
source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed
validpgpkeys = 9EF1E80F3817BC043097A7C15814977902B194CC
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b05c84596b17..e6cf855e4e41 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,12 @@ This project adheres to [Semantic Versioning](https://semver.org/) since version
## [Unreleased]
+## [13.6.0] - 2022-02-19
+### Added
+- `BasicMixer` and `Channel` classes added to `tcod.sdl.audio`. These handle simple audio mixing.
+- `AudioDevice.convert` added to handle simple conversions to the active devices format.
+- `tcod.sdl.audio.convert_audio` added to handle any other conversions needed.
+
## [13.5.0] - 2022-02-11
### Added
- `tcod.sdl.audio`, a new module exposing SDL audio devices. This does not include an audio mixer yet.
diff --git a/PKGBUILD b/PKGBUILD
index 62d823a72583..d066e507ff6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.5.0
+pkgver=13.6.0
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
@@ -13,7 +13,7 @@ url='https://github.com/libtcod/python-tcod'
license=('BSD')
depends=('python-cffi' 'python-numpy' 'python-typing_extensions' 'sdl2')
makedepends=(
- 'git' 'python-setuptools' 'python-build' 'python-install' 'python-wheel'
+ 'git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel'
'python-pytest-runner' 'python-pycparser' 'python-pcpp' 'python-sphinx')
changelog=CHANGELOG.md
source=(
@@ -46,7 +46,7 @@ build() {
package() {
export PYTHONHASHSEED=0
cd "$pkgname"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 docs/_build/man/python-tcod.1 -t "$pkgdir/usr/share/man/man1/"
}