summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-29 23:07:00 -0500
committerLuis Martinez2022-03-29 23:07:00 -0500
commitb78a631cd344e0d8b42b5055fe1fab5f049e595a (patch)
treeeba3d7f6893d99274cfb6e102f590967d17c9dd1
parentb724ba5fe80e2c7c249ce92f086f1aa2d8d537f8 (diff)
downloadaur-b78a631cd344e0d8b42b5055fe1fab5f049e595a.tar.gz
update to 13.6.1
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG.md5
-rw-r--r--PKGBUILD12
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f7d05ecb451..0040fac98637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tcod
pkgdesc = High-performance Python port of libtcod
- pkgver = 13.6.0
+ pkgver = 13.6.1
pkgrel = 1
url = https://github.com/libtcod/python-tcod
changelog = CHANGELOG.md
@@ -19,7 +19,7 @@ pkgbase = python-tcod
depends = python-numpy
depends = python-typing_extensions
depends = sdl2
- source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.6.0?signed
+ source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.6.1?signed
source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed
validpgpkeys = 9EF1E80F3817BC043097A7C15814977902B194CC
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e6cf855e4e41..0874c558e4a6 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,11 @@ This project adheres to [Semantic Versioning](https://semver.org/) since version
## [Unreleased]
+## [13.6.1] - 2022-03-29
+### Changed
+- The SDL2 renderer has had a major performance update when compiled with SDL 2.0.18.
+- SDL2 is now the default renderer to avoid rare issues with the OpenGL 2 renderer.
+
## [13.6.0] - 2022-02-19
### Added
- `BasicMixer` and `Channel` classes added to `tcod.sdl.audio`. These handle simple audio mixing.
diff --git a/PKGBUILD b/PKGBUILD
index d066e507ff6c..51e09d926c46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.6.0
+pkgver=13.6.1
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
@@ -33,8 +33,7 @@ prepare() {
build() {
cd "$pkgname"
python -m build --wheel --skip-dependency-check --no-isolation
- cd docs
- make man
+ make -C docs man
}
# check() {
@@ -47,6 +46,11 @@ package() {
export PYTHONHASHSEED=0
cd "$pkgname"
python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 docs/_build/man/python-tcod.1 -t "$pkgdir/usr/share/man/man1/"
+
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/tcod-$pkgver.dist-info/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}