summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-11-26 14:23:14 -0600
committerLuis Martinez2021-11-26 14:23:14 -0600
commite56ea8f3b7daf84ffe6c7409fe2f6798b60492ed (patch)
treedf7ae4213b3a9bc12139f1c260f8f4db95f13ee6
parent76a744c8655704898348e423314895130a32c87b (diff)
downloadaur-e56ea8f3b7daf84ffe6c7409fe2f6798b60492ed.tar.gz
update to 13.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5466913bd954..e7a6426bb402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tcod
pkgdesc = High-performance Python port of libtcod
- pkgver = 13.0.0
+ pkgver = 13.1.0
pkgrel = 1
url = https://github.com/libtcod/python-tcod
arch = x86_64
@@ -8,14 +8,14 @@ pkgbase = python-tcod
makedepends = git
makedepends = python-setuptools
makedepends = python-pytest-runner
- makedepends = python-pycparser>=2.14
+ makedepends = python-pycparser
makedepends = python-sphinx
- makedepends = sdl2>=2.0.5
+ makedepends = sdl2
depends = python-cffi
- depends = python-numpy>=1.20.3
+ depends = python-numpy
depends = python-typing_extensions
- source = python-tcod-13.0.0::git+https://github.com/libtcod/python-tcod#tag=13.0.0?signed
- source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.18.1?signed
+ source = python-tcod-13.1.0::git+https://github.com/libtcod/python-tcod#tag=13.1.0?signed
+ source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.19.0?signed
validpgpkeys = 9EF1E80F3817BC043097A7C15814977902B194CC
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6719fe9ce818..533adf00aba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,25 @@
# Contributor: Maximilian Stahlberg <maximilian.stahlberg tu-berlin de>
# Contributor: Feufochmar <feufochmar dot gd at gmail dot com>
+## Cannot use libtcod as dependency; statically linked
+
pkgname=python-tcod
-pkgver=13.0.0
+pkgver=13.1.0
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
url='https://github.com/libtcod/python-tcod'
license=('BSD')
-depends=(
- 'python-cffi'
- 'python-numpy>=1.20.3'
- 'python-typing_extensions')
+depends=('python-cffi' 'python-numpy' 'python-typing_extensions')
makedepends=(
'git'
'python-setuptools'
'python-pytest-runner'
- 'python-pycparser>=2.14'
+ 'python-pycparser'
'python-sphinx'
- 'sdl2>=2.0.5')
+ 'sdl2')
source=("$pkgname-$pkgver::git+$url#tag=$pkgver?signed"
- 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.18.1?signed')
+ 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.19.0?signed')
sha256sums=('SKIP'
'SKIP')
validpgpkeys=('9EF1E80F3817BC043097A7C15814977902B194CC') # Kyle Benesch @ GitHub
@@ -49,6 +48,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm 644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm 644 docs/_build/man/python-tcod.1 -t "$pkgdir/usr/share/man/man1/"
+ install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 docs/_build/man/python-tcod.1 -t "$pkgdir/usr/share/man/man1/"
}