summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-02-20 18:39:21 -0500
committerCarlos Aznarán Laos2023-02-20 18:39:21 -0500
commit78ac56413b684885ec6637b6271b282d0d4c8b68 (patch)
tree525f83ce8eca8f16511382ea442a654a8ad73ea2
downloadaur-78ac56413b684885ec6637b6271b282d0d4c8b68.tar.gz
Bump version to 0.1.4
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD30
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8fa6d6591f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-tcx2gpx
+ pkgdesc = Converts the Garmin tcx GPS file format to the more commonly used gpx file format
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://gitlab.com/nshephard/tcx2gpx
+ arch = any
+ license = GPL3
+ checkdepends = python-pytest-cov
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python-gpxpy
+ depends = python-tcxparser
+ depends = python-tqdm
+ source = https://gitlab.com/nshephard/tcx2gpx/-/archive/0.1.4/tcx2gpx-0.1.4.tar.gz
+ sha512sums = 3a3b57b3de998e05bd23a383d19a3ef1a4ed3fd9959cde44a5d97b6fab9058426d326502bc4ed0e14fdce74d61b3e5ea01acf2eb57b02a1d58dbad55f3b0cff6
+
+pkgname = python-tcx2gpx
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4878c5b032eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=tcx2gpx
+pkgname=python-${_base}
+pkgdesc="Converts the Garmin tcx GPS file format to the more commonly used gpx file format"
+pkgver=0.1.4
+pkgrel=1
+arch=(any)
+url="https://gitlab.com/nshephard/${_base}"
+license=(GPL3)
+depends=(python-gpxpy python-tcxparser python-tqdm)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(python-pytest-cov)
+source=(${url}/-/archive/0.1.4/${_base}-${pkgver}.tar.gz)
+sha512sums=('3a3b57b3de998e05bd23a383d19a3ef1a4ed3fd9959cde44a5d97b6fab9058426d326502bc4ed0e14fdce74d61b3e5ea01acf2eb57b02a1d58dbad55f3b0cff6')
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m pytest
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}