summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12019-08-30 00:44:31 +0500
committerevgfilim12019-08-30 00:44:31 +0500
commit4a932a97d67ffcbbc5acf202750253bc92a7ad7b (patch)
tree208e61c0e9c2a6da0e0b0334e7eaaa994da88e31
parentbe58ae633773779b83d07c50cec83a7158d576b7 (diff)
downloadaur-4a932a97d67ffcbbc5acf202750253bc92a7ad7b.tar.gz
Updated to version 1:12.0.0.r0
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGES.rst49
-rw-r--r--PKGBUILD2
3 files changed, 45 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fe0f2a57874..be4192bf7075 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 12.0.0b1.r23.24546bda
+ pkgver = 12.0.0.r0.c84e21d8
pkgrel = 1
epoch = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
diff --git a/CHANGES.rst b/CHANGES.rst
index ba4ac1d27e8e..c3e72aa07bc5 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,22 +2,25 @@
Changelog
=========
-Version 12.0.0b1
+Version 12.0.0
================
-*Released 2019-02-13*
+*Released 2019-08-29*
-First beta release ever.
-It has been so long since last release that we would like to test the impact before a final release.
+Well... This felt like decades. But here we are with a new release.
-*We do NOT recommend using this beta release in production.*
+Expect minor releases soon (mainly complete Bot API 4.4 support)
-**Major changes:**
+**Major and/or breaking changes:**
- Context based callbacks
- Persistence
- PrefixHandler added (Handler overhaul)
- Deprecation of RegexHandler and edited_messages, channel_post, etc. arguments (Filter overhaul)
- Various ConversationHandler changes and fixes
+- Bot API 4.1, 4.2, 4.3 support
+- Python 3.4 is no longer supported
+- Error Handler now handles all types of exceptions (`#1485`_)
+- Return UTC from from_timestamp() (`#1485`_)
**See the wiki page at https://git.io/fxJuV for a detailed guide on how to migrate from version 11 to version 12.**
@@ -64,6 +67,7 @@ ConversationHandler
- Use warnings.warn for ConversationHandler warnings (`#1343`_)
- Fix unresolvable promises (`#1270`_)
+
Bug fixes & improvements
------------------------
@@ -82,6 +86,22 @@ Bug fixes & improvements
- Allow SOCKSConnection to parse username and password from URL (`#1211`_)
- Fix for arguments in passport/data.py (`#1213`_)
- Improve message entity parsing by adding text_mention (`#1206`_)
+- Documentation fixes (`#1348`_, `#1397_`, `#1436`_)
+- Merged filters short-circuit (`#1350`_)
+- Fix webhook listen with tornado (`#1383`_)
+- Call task_done() on update queue after update processing finished (`#1428`_)
+- Fix send_location() - latitude may be 0 (`#1437`_)
+- Make MessageEntity objects comparable (`#1465`_)
+- Add prefix to thread names (`#1358`_)
+
+Buf fixes since v12.0.0b1
+-------------------------
+
+- Fix setting bot on ShippingQuery (`#1355`_)
+- Fix _trigger_timeout() missing 1 required positional argument: 'job' (`#1367`_)
+- Add missing message.text check in PrefixHandler check_update (`#1375`_)
+- Make updates persist even on DispatcherHandlerStop (`#1463`_)
+- Dispatcher force updating persistence object's chat data attribute(`#1462`)
.. _`#1100`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1100
.. _`#1283`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1283
@@ -110,6 +130,22 @@ Bug fixes & improvements
.. _`#1319`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1319
.. _`#1343`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1343
.. _`#1270`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1270
+.. _`#1348`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1348
+.. _`#1350`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1350
+.. _`#1383`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1383
+.. _`#1397`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1397
+.. _`#1428`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1428
+.. _`#1436`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1436
+.. _`#1437`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1437
+.. _`#1465`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1465
+.. _`#1358`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1358
+.. _`#1355`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1355
+.. _`#1367`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1367
+.. _`#1375`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1375
+.. _`#1463`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1463
+.. _`#1462`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1462
+.. _`#1483`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1483
+.. _`#1485`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1485
Internal improvements
---------------------
@@ -118,6 +154,7 @@ Internal improvements
- Use multiple bots for CI to improve testing times significantly.
- Allow pypy to fail in CI.
- Remove the last CamelCase CheckUpdate methods from the handlers we missed earlier.
+- test_official is now executed in a different job
Version 11.1.0
==============
diff --git a/PKGBUILD b/PKGBUILD
index a2905b898953..531c2ce6eee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
epoch=1
-pkgver=12.0.0b1.r23.24546bda
+pkgver=12.0.0.r0.c84e21d8
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')