summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12021-02-20 00:20:03 +0500
committerevgfilim12021-02-20 00:21:19 +0500
commit5dba544d4bf12ef2a4c061d6b065ef42485d8bfa (patch)
tree074923b94e8c2c5886d5b20540c9fb039cbecc51
parent0b24e67a4d5167aea809584b814fffbbfda9a251 (diff)
downloadaur-5dba544d4bf12ef2a4c061d6b065ef42485d8bfa.tar.gz
Updated to version 1:13.3.r0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGES.rst25
-rw-r--r--PKGBUILD11
3 files changed, 34 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3753afd94cc8..3f583cfe0393 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 13.2.r2.a34f0b9b
+ pkgver = 13.3.r0.e9c01c77
pkgrel = 1
epoch = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
@@ -11,11 +11,11 @@ pkgbase = python-telegram-bot-git
makedepends = python-setuptools
depends = python-certifi
depends = python-tornado>=5.1
- depends = python-cryptography
depends = python-apscheduler
depends = python-pytz>=2018.6
- optdepends = python-pysocks: SOCKS or HTTP proxy
+ optdepends = python-pysocks: SOCKS or HTTP proxy support
optdepends = python-ujson: Ultra fast JSON parsing
+ optdepends = python-cryptography: Telegram Passport support
provides = python-telegram-bot
conflicts = python-telegram-bot
source = python-telegram-bot::git+https://github.com/python-telegram-bot/python-telegram-bot.git
diff --git a/CHANGES.rst b/CHANGES.rst
index 95fff6a35910..cfe45dc23e0d 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,6 +2,31 @@
Changelog
=========
+Version 13.3
+============
+*Released 2021-02-19*
+
+**Major Changes:**
+
+- Make ``cryptography`` Dependency Optional & Refactor Some Tests (`#2386`_, `#2370`_)
+- Deprecate ``MessageQueue`` (`#2393`_)
+
+**Bug Fixes:**
+
+- Refactor ``Defaults`` Integration (`#2363`_)
+- Add Missing ``telegram.SecureValue`` to init and Docs (`#2398`_)
+
+**Minor changes:**
+
+- Doc Fixes (`#2359`_)
+
+.. _`#2386`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2386
+.. _`#2370`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2370
+.. _`#2393`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2393
+.. _`#2363`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2363
+.. _`#2398`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2398
+.. _`#2359`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2359
+
Version 13.2
============
*Released 2021-02-02*
diff --git a/PKGBUILD b/PKGBUILD
index ebd9c629325c..6daf105faef4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
# Co-Maintainer: Ke Liu <specter119@gmail.com>
+
pkgname=('python-telegram-bot-git')
epoch=1
-pkgver=13.2.r2.a34f0b9b
+pkgver=13.3.r0.e9c01c77
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')
@@ -12,7 +13,6 @@ license=('LGPL3')
depends=(
'python-certifi'
'python-tornado>=5.1'
- 'python-cryptography' # only outdated 3.3.1 in official repos, latest is 3.4.2
'python-apscheduler'
'python-pytz>=2018.6'
)
@@ -21,15 +21,16 @@ makedepends=(
'python-setuptools'
)
optdepends=(
- 'python-pysocks: SOCKS or HTTP proxy'
+ 'python-pysocks: SOCKS or HTTP proxy support'
'python-ujson: Ultra fast JSON parsing'
+ 'python-cryptography: Telegram Passport support' # [extra]: 3.3.1, [testing]: 3.4.6
)
provides=($_provide)
conflicts=($_provide)
changelog='CHANGES.rst'
source=(
$_provide::git+${url}.git
- urllib3::git+https://github.com/python-telegram-bot/urllib3.git#branch=ptb
+ "urllib3::git+https://github.com/python-telegram-bot/urllib3.git#branch=ptb"
)
sha256sums=('SKIP' 'SKIP')
@@ -41,7 +42,7 @@ prepare() {
git submodule update
msg2 "Updating changelog..."
cp ./CHANGES.rst ../../
- msg2 "Unpin python-apscheduler..."
+ msg2 "Unpinning python-apscheduler..."
sed -i 's/APScheduler==.*$/APScheduler/' requirements.txt
}