summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12017-09-20 18:42:56 +0000
committerevgfilim12017-09-20 18:42:56 +0000
commit6b7bb6d3a099b77b55b4d4152e744613919ce35c (patch)
treed2403e43d91dd887b3ab4cfdf8e6a0114ad23121
parent7fa9aa4fe69dbe402fc7a88c8e2c429f91a93718 (diff)
downloadaur-6b7bb6d3a099b77b55b4d4152e744613919ce35c.tar.gz
Updated to version 8.0.r7
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGES.rst41
-rw-r--r--PKGBUILD2
3 files changed, 43 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b51266c20a88..66340a734fad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 7.0.1.r22.16a49ec
+ pkgver = 8.0.r7.5614af1
pkgrel = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
changelog = CHANGES.rst
diff --git a/CHANGES.rst b/CHANGES.rst
index 5e8ed0429051..52512c252465 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,47 @@
=======
Changes
=======
+**2017-09-01**
+*Released 8.0.0*
+
+New features
+
+- Fully support Bot Api 3.3 (PR `#806`_).
+- DispatcherHandlerStop (`see docs`_).
+- Regression fix for text_html & text_markdown (PR `#777`_).
+- Added effective_attachment to message (PR `#766`_).
+
+Non backward compatible changes
+
+- Removed Botan support from the library (PR `#776`_).
+- Fully support Bot Api 3.3 (PR `#806`_).
+- Remove de_json() (PR `#789`_).
+
+Changes
+
+- Sane defaults for tcp socket options on linux (PR `#754`_).
+- Add RESTRICTED as constant to ChatMember (PR `#761`_).
+- Add rich comparison to CallbackQuery (PR `#764`_).
+- Fix get_game_high_scores (PR `#771`_).
+- Warn on small con_pool_size during custom initalization of Updater (PR `#793`_).
+- Catch exceptions in error handlerfor errors that happen during polling (PR `#810`_).
+- For testing we switched to pytest (PR `#788`_).
+- Lot's of small improvements to our tests and documentation.
+
+
+.. _`see docs`: http://python-telegram-bot.readthedocs.io/en/stable/telegram.ext.dispatcher.html#telegram.ext.Dispatcher.add_handler
+.. _`#777`: https://github.com/python-telegram-bot/python-telegram-bot/pull/777
+.. _`#806`: https://github.com/python-telegram-bot/python-telegram-bot/pull/806
+.. _`#766`: https://github.com/python-telegram-bot/python-telegram-bot/pull/766
+.. _`#776`: https://github.com/python-telegram-bot/python-telegram-bot/pull/776
+.. _`#789`: https://github.com/python-telegram-bot/python-telegram-bot/pull/789
+.. _`#754`: https://github.com/python-telegram-bot/python-telegram-bot/pull/754
+.. _`#761`: https://github.com/python-telegram-bot/python-telegram-bot/pull/761
+.. _`#764`: https://github.com/python-telegram-bot/python-telegram-bot/pull/764
+.. _`#771`: https://github.com/python-telegram-bot/python-telegram-bot/pull/771
+.. _`#788`: https://github.com/python-telegram-bot/python-telegram-bot/pull/788
+.. _`#793`: https://github.com/python-telegram-bot/python-telegram-bot/pull/793
+.. _`#810`: https://github.com/python-telegram-bot/python-telegram-bot/pull/810
**2017-07-28**
*Released 7.0.1*
diff --git a/PKGBUILD b/PKGBUILD
index 6f935d8ae6d5..505d0b71d2e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
-pkgver=7.0.1.r22.16a49ec
+pkgver=8.0.r7.5614af1
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')