summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12017-11-27 15:54:49 +0500
committerevgfilim12017-11-27 15:54:49 +0500
commit7f3c05bd88a6c0c16ce6a3cb9dad823d75a333a3 (patch)
treea44625a1a793664670b045b1057d15806a5eede3
parent6b7bb6d3a099b77b55b4d4152e744613919ce35c (diff)
downloadaur-7f3c05bd88a6c0c16ce6a3cb9dad823d75a333a3.tar.gz
Updated to version 8.1.1.r8
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGES.rst27
-rw-r--r--PKGBUILD4
3 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66340a734fad..6b0dfc0bd5b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 8.0.r7.5614af1
+ pkgver = 8.1.1.r8.e8fac19
pkgrel = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
changelog = CHANGES.rst
@@ -8,7 +8,7 @@ pkgbase = python-telegram-bot-git
license = LGPL3
makedepends = git
makedepends = python-setuptools
- depends = python-future>=0.15.2
+ depends = python-future>=0.16.0
depends = python-certifi
optdepends = python-pysocks: SOCKS or HTTP proxy
optdepends = python-ujson: Ultra fast JSON parsing
diff --git a/CHANGES.rst b/CHANGES.rst
index 52512c252465..fec0cb766fe8 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,31 @@
=======
Changes
=======
+**2017-10-15**
+*Released 8.1.1*
+
+- Fix Commandhandler crashing on single character messages (PR `#873`_).
+
+.. _`#873`: https://github.com/python-telegram-bot/python-telegram-bot/pull/871
+
+**2017-10-14**
+*Released 8.1.0*
+
+New features
+- Support Bot API 3.4 (PR `#865`_).
+
+Changes
+- MessageHandler & RegexHandler now consider channel_updates.
+- Fix command not recognized if it is directly followed by a newline (PR `#869`_).
+- Removed Bot._message_wrapper (PR `#822`_).
+- Unitests are now also running on AppVeyor (Windows VM).
+- Various unitest improvements.
+- Documentation fixes.
+
+.. _`#822`: https://github.com/python-telegram-bot/python-telegram-bot/pull/822
+.. _`#865`: https://github.com/python-telegram-bot/python-telegram-bot/pull/865
+.. _`#869`: https://github.com/python-telegram-bot/python-telegram-bot/pull/869
+
**2017-09-01**
*Released 8.0.0*
@@ -26,7 +51,7 @@ Changes
- Warn on small con_pool_size during custom initalization of Updater (PR `#793`_).
- Catch exceptions in error handlerfor errors that happen during polling (PR `#810`_).
- For testing we switched to pytest (PR `#788`_).
-- Lot's of small improvements to our tests and documentation.
+- Lots of small improvements to our tests and documentation.
.. _`see docs`: http://python-telegram-bot.readthedocs.io/en/stable/telegram.ext.dispatcher.html#telegram.ext.Dispatcher.add_handler
diff --git a/PKGBUILD b/PKGBUILD
index 505d0b71d2e8..8da74f1f69f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
-pkgver=8.0.r7.5614af1
+pkgver=8.1.1.r8.e8fac19
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')
url="https://github.com/${pkgname%-git}/${pkgname%-git}"
license=('LGPL3')
-depends=('python-future>=0.15.2' 'python-certifi')
+depends=('python-future>=0.16.0' 'python-certifi')
makedepends=('git' 'python-setuptools')
optdepends=('python-pysocks: SOCKS or HTTP proxy'
'python-ujson: Ultra fast JSON parsing')