summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12018-10-14 11:46:08 +0500
committerevgfilim12018-10-14 11:46:08 +0500
commit9ebd9fbff730ca6a46ad879f6a8cf90a85eeaf7c (patch)
treeff0a37f48f1bd483d73b2608705dec1fa60feac5
parente1d5ec221aa21824f3e1690546ef276470e026f5 (diff)
downloadaur-9ebd9fbff730ca6a46ad879f6a8cf90a85eeaf7c.tar.gz
Updated to version 1:11.1.0.r39
-rw-r--r--.SRCINFO5
-rw-r--r--CHANGES.rst72
-rw-r--r--PKGBUILD5
3 files changed, 79 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9af20cb28097..2338923cc6fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 10.1.0.r11.d4b5bd40
+ pkgver = 11.1.0.r39.9ece7fdb
pkgrel = 1
+ epoch = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
changelog = CHANGES.rst
arch = any
@@ -10,6 +11,8 @@ pkgbase = python-telegram-bot-git
makedepends = python-setuptools
depends = python-future>=0.16.0
depends = python-certifi
+ depends = python-tornado>=5.1
+ depends = python-cryptography
optdepends = python-pysocks: SOCKS or HTTP proxy
optdepends = python-ujson: Ultra fast JSON parsing
provides = python-telegram-bot
diff --git a/CHANGES.rst b/CHANGES.rst
index 1d5fe1f74f93..69b908a8c44a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,78 @@
=======
Changes
=======
+
+**2018-09-01**
+*Released 11.1.0*
+
+Fixes and updates for Telegram Passport: (`#1198`_)
+
+- Fix passport decryption failing at random times
+- Added support for middle names.
+- Added support for translations for documents
+- Add errors for translations for documents
+- Added support for requesting names in the language of the user's country of residence
+- Replaced the payload parameter with the new parameter nonce
+- Add hash to EncryptedPassportElement
+
+.. _`#1198`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1198
+
+**2018-08-29**
+*Released 11.0.0*
+
+Fully support Bot API version 4.0!
+(also some bugfixes :))
+
+Telegram Passport (`#1174`_):
+
+- Add full support for telegram passport.
+ - New types: PassportData, PassportFile, EncryptedPassportElement, EncryptedCredentials, PassportElementError, PassportElementErrorDataField, PassportElementErrorFrontSide, PassportElementErrorReverseSide, PassportElementErrorSelfie, PassportElementErrorFile and PassportElementErrorFiles.
+ - New bot method: set_passport_data_errors
+ - New filter: Filters.passport_data
+ - Field passport_data field on Message
+ - PassportData can be easily decrypted.
+ - PassportFiles are automatically decrypted if originating from decrypted PassportData.
+- See new passportbot.py example for details on how to use, or go to `our telegram passport wiki page`_ for more info
+- NOTE: Passport decryption requires new dependency `cryptography`.
+
+Inputfile rework (`#1184`_):
+
+- Change how Inputfile is handled internally
+- This allows support for specifying the thumbnails of photos and videos using the thumb= argument in the different send\_ methods.
+- Also allows Bot.send_media_group to actually finally send more than one media.
+- Add thumb to Audio, Video and Videonote
+- Add Bot.edit_message_media together with InputMediaAnimation, InputMediaAudio, and inputMediaDocument.
+
+Other Bot API 4.0 changes:
+
+- Add forusquare_type to Venue, InlineQueryResultVenue, InputVenueMessageContent, and Bot.send_venue. (`#1170`_)
+- Add vCard support by adding vcard field to Contact, InlineQueryResultContact, InputContactMessageContent, and Bot.send_contact. (`#1166`_)
+- Support new message entities: CASHTAG and PHONE_NUMBER. (`#1179`_)
+ - Cashtag seems to be things like `$USD` and `$GBP`, but it seems telegram doesn't currently send them to bots.
+ - Phone number also seems to have limited support for now
+- Add Bot.send_animation, add width, height, and duration to Animation, and add Filters.animation. (`#1172`_)
+
+Non Bot API 4.0 changes:
+
+- Minor integer comparison fix (`#1147`_)
+- Fix Filters.regex failing on non-text message (`#1158`_)
+- Fix ProcessLookupError if process finishes before we kill it (`#1126`_)
+- Add t.me links for User, Chat and Message if available and update User.mention_* (`#1092`_)
+- Fix mention_markdown/html on py2 (`#1112`_)
+
+.. _`#1092`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1092
+.. _`#1112`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1112
+.. _`#1126`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1126
+.. _`#1147`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1147
+.. _`#1158`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1158
+.. _`#1166`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1166
+.. _`#1170`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1170
+.. _`#1174`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1174
+.. _`#1172`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1172
+.. _`#1179`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1179
+.. _`#1184`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1184
+.. _`our telegram passport wiki page`: https://git.io/fAvYd
+
**2018-05-02**
*Released 10.1.0*
diff --git a/PKGBUILD b/PKGBUILD
index 90b6af6b0159..43ad67c871c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
-pkgver=10.1.0.r11.d4b5bd40
+epoch=1
+pkgver=11.1.0.r39.9ece7fdb
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')
url="https://github.com/${pkgname%-git}/${pkgname%-git}"
license=('LGPL3')
-depends=('python-future>=0.16.0' 'python-certifi')
+depends=('python-future>=0.16.0' 'python-certifi' 'python-tornado>=5.1' 'python-cryptography')
makedepends=('git' 'python-setuptools')
optdepends=('python-pysocks: SOCKS or HTTP proxy'
'python-ujson: Ultra fast JSON parsing')