summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12021-02-11 12:10:27 +0500
committerevgfilim12021-02-11 12:12:58 +0500
commita7bb325bc35a21cded74f8a6e94a6399d4e41a64 (patch)
treea05d963ecd539d06ec7efc2466e5d8a757e83e50
parent0b1552d51afbfcf2a9a928503a8a0d167247fac9 (diff)
downloadaur-a7bb325bc35a21cded74f8a6e94a6399d4e41a64.tar.gz
Don't lock python-apscheduler version
Add urllib3 submodule into sources array Remove unneeded dependencies Refactor PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGES.rst67
-rw-r--r--PKGBUILD32
3 files changed, 92 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18f75277b16e..8c4831534382 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 13.1.r1.e0dbb99b
- pkgrel = 1
+ pkgver = 13.2.r1.eee89215
+ pkgrel = 2
epoch = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
changelog = CHANGES.rst
@@ -9,18 +9,18 @@ pkgbase = python-telegram-bot-git
license = LGPL3
makedepends = git
makedepends = python-setuptools
- depends = python-future>=0.16.0
depends = python-certifi
depends = python-tornado>=5.1
depends = python-cryptography
- depends = python-decorator>=4.4.0
- depends = python-apscheduler=3.6.3
+ depends = python-apscheduler
depends = python-pytz>=2018.6
optdepends = python-pysocks: SOCKS or HTTP proxy
optdepends = python-ujson: Ultra fast JSON parsing
provides = python-telegram-bot
conflicts = python-telegram-bot
source = python-telegram-bot-git::git+https://github.com/python-telegram-bot/python-telegram-bot.git
+ source = urllib3::git+https://github.com/python-telegram-bot/urllib3.git#branch=ptb
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = python-telegram-bot-git
diff --git a/CHANGES.rst b/CHANGES.rst
index 801ab90e0ae8..95fff6a35910 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,6 +2,73 @@
Changelog
=========
+Version 13.2
+============
+*Released 2021-02-02*
+
+**Major Changes:**
+
+- Introduce ``python-telegram-bot-raw`` (`#2324`_)
+- Explicit Signatures for Shortcuts (`#2240`_)
+
+**New Features:**
+
+- Add Missing Shortcuts to ``Message`` (`#2330`_)
+- Rich Comparison for ``Bot`` (`#2320`_)
+- Add ``run_async`` Parameter to ``ConversationHandler`` (`#2292`_)
+- Add New Shortcuts to ``Chat`` (`#2291`_)
+- Add New Constant ``MAX_ANSWER_CALLBACK_QUERY_TEXT_LENGTH`` (`#2282`_)
+- Allow Passing Custom Filename For All Media (`#2249`_)
+- Handle Bytes as File Input (`#2233`_)
+
+**Bug Fixes:**
+
+- Fix Escaping in Nested Entities in ``Message`` Properties (`#2312`_)
+- Adjust Calling of ``Dispatcher.update_persistence`` (`#2285`_)
+- Add ``quote`` kwarg to ``Message.reply_copy`` (`#2232`_)
+- ``ConversationHandler``: Docs & ``edited_channel_post`` behavior (`#2339`_)
+
+**Minor changes, CI improvements, doc fixes and type hinting:**
+
+- Doc Fixes (`#2253`_, `#2225`_)
+- Reduce Usage of ``typing.Any`` (`#2321`_)
+- Extend Deeplinking Example (`#2335`_)
+- Add pyupgrade to pre-commit Hooks (`#2301`_)
+- Add PR Template (`#2299`_)
+- Drop Nightly Tests & Update Badges (`#2323`_)
+- Update Copyright (`#2289`_, `#2287`_)
+- Change Order of Class DocStrings (`#2256`_)
+- Add macOS to Test Matrix (`#2266`_)
+- Start Using Versioning Directives in Docs (`#2252`_)
+- Improve Annotations & Docs of Handlers (`#2243`_)
+
+.. _`#2324`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2324
+.. _`#2240`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2240
+.. _`#2330`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2330
+.. _`#2320`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2320
+.. _`#2292`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2292
+.. _`#2291`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2291
+.. _`#2282`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2282
+.. _`#2249`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2249
+.. _`#2233`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2233
+.. _`#2312`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2312
+.. _`#2285`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2285
+.. _`#2232`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2232
+.. _`#2339`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2339
+.. _`#2253`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2253
+.. _`#2225`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2225
+.. _`#2321`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2321
+.. _`#2335`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2335
+.. _`#2301`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2301
+.. _`#2299`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2299
+.. _`#2323`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2323
+.. _`#2289`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2289
+.. _`#2287`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2287
+.. _`#2256`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2256
+.. _`#2266`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2266
+.. _`#2252`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2252
+.. _`#2243`: https://github.com/python-telegram-bot/python-telegram-bot/pull/2243
+
Version 13.1
============
*Released 2020-11-29*
diff --git a/PKGBUILD b/PKGBUILD
index deae9f31edd8..a5800ca7c889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,42 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
epoch=1
-pkgver=13.1.r1.e0dbb99b
-pkgrel=1
+pkgver=13.2.r1.eee89215
+pkgrel=2
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')
url="https://github.com/${pkgname%-git}/${pkgname%-git}"
license=('LGPL3')
depends=(
- 'python-future>=0.16.0'
'python-certifi'
'python-tornado>=5.1'
- 'python-cryptography'
- 'python-decorator>=4.4.0'
- 'python-apscheduler=3.6.3'
+ 'python-cryptography' # only outdated 3.3.1 in official repos, latest is 3.4.2
+ 'python-apscheduler'
'python-pytz>=2018.6'
)
-makedepends=('git' 'python-setuptools')
-optdepends=('python-pysocks: SOCKS or HTTP proxy'
- 'python-ujson: Ultra fast JSON parsing')
+makedepends=(
+ 'git'
+ 'python-setuptools'
+)
+optdepends=(
+ 'python-pysocks: SOCKS or HTTP proxy'
+ 'python-ujson: Ultra fast JSON parsing'
+)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
changelog='CHANGES.rst'
-source=("${pkgname}::git+${url}.git")
-sha256sums=('SKIP')
+source=(
+ "${pkgname}::git+${url}.git"
+ "urllib3::git+https://github.com/python-telegram-bot/urllib3.git#branch=ptb"
+)
+sha256sums=('SKIP' 'SKIP')
prepare() {
msg2 "Updating dependencies..."
cd "$srcdir/$pkgname"
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.telegram/vendor/urllib3.url "$srcdir/urllib3"
+ git submodule update
msg2 "Updating changelog..."
cp ./CHANGES.rst ../../
}