summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12020-01-13 17:40:29 +0500
committerevgfilim12020-01-13 17:40:29 +0500
commitb5afa9141016b29902d85af45137d9c243aa074b (patch)
treebbe3e337eb177c770faf72c5e15883fd280df955
parent889d434af7ae05f2546e77e1bea9b586dddd7578 (diff)
downloadaur-b5afa9141016b29902d85af45137d9c243aa074b.tar.gz
Updated to version 1:12.3.0.r0
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGES.rst51
-rw-r--r--PKGBUILD2
3 files changed, 53 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03f96b379f47..ebf88e778093 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 12.2.0.r0.98147fce
+ pkgver = 12.3.0.r0.1e7f4fae
pkgrel = 1
epoch = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
diff --git a/CHANGES.rst b/CHANGES.rst
index 871c8e911bd3..27fbf804b484 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,8 +2,59 @@
Changelog
=========
+Version 12.3.0
+==============
+*Released 2020-01-11*
+
+**New features:**
+
+- `Filters.caption` allows only messages with caption (`#1631`_).
+- Filter for exact messages/captions with new capability of `Filters.text` and `Filters.caption`. Especially useful in combination with ReplyKeyboardMarkup. (`#1631`_).
+
+**Major changes:**
+
+- Fix inconsistent handling of naive datetimes (`#1506`_).
+
+**Minor changes, CI improvments or bug fixes:**
+
+- Documentation fixes (`#1558`_, `#1569`_, `#1579`_, `#1572`_, `#1566`_, `#1577`_, `#1656`_).
+- Add mutex protection on `ConversationHandler` (`#1533`_).
+- Add `MAX_PHOTOSIZE_UPLOAD` constant (`#1560`_).
+- Add args and kwargs to `Message.forward()` (`#1574`_).
+- Transfer to GitHub Actions CI (`#1555`_, `#1556`_, `#1605`_, `#1606`_, `#1607`_, `#1612`_, `#1615`_, `#1645`_).
+- Fix deprecation warning with Py3.8 by vendored urllib3 (`#1618`_).
+- Simplify assignements for optional arguments (`#1600`_)
+- Allow private groups for `Message.link` (`#1619`_).
+- Fix wrong signature call for `ConversationHandler.TIMEOUT` handlers (`#1653`_).
+
+.. _`#1631`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1558
+.. _`#1506`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1506
+.. _`#1558`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1558
+.. _`#1569`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1569
+.. _`#1579`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1579
+.. _`#1572`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1572
+.. _`#1566`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1566
+.. _`#1577`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1577
+.. _`#1533`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1533
+.. _`#1560`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1560
+.. _`#1574`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1574
+.. _`#1555`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1555
+.. _`#1556`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1556
+.. _`#1605`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1605
+.. _`#1606`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1606
+.. _`#1607`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1607
+.. _`#1612`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1612
+.. _`#1615`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1615
+.. _`#1618`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1618
+.. _`#1600`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1600
+.. _`#1619`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1619
+.. _`#1653`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1653
+.. _`#1656`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1656
+.. _`#1645`: https://github.com/python-telegram-bot/python-telegram-bot/pull/1645
+
Version 12.2.0
==============
+*Released 2019-10-14*
**New features:**
diff --git a/PKGBUILD b/PKGBUILD
index 37c9e6bcfe7f..8b2bbcf5bbe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
epoch=1
-pkgver=12.2.0.r0.98147fce
+pkgver=12.3.0.r0.1e7f4fae
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')