summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12017-05-20 07:47:52 +0500
committerevgfilim12017-05-20 07:53:35 +0500
commiteb49242f1775cee2193d4723f8993eca7d3c9107 (patch)
tree5c2d9a578d3b191972b3991944b712e69dd208c8
parent9c5f9109592618d39d085d0011162684600f651c (diff)
downloadaur-eb49242f1775cee2193d4723f8993eca7d3c9107.tar.gz
Updated to version 6.0.0
Now using `git describe --tags` in `pkgver()`
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGES.rst21
-rw-r--r--PKGBUILD7
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5811a0e86f3..17caad710c6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 5.3.1.r1451.e2a651a
+ pkgver = 6.0.0
pkgrel = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
changelog = CHANGES.rst
diff --git a/CHANGES.rst b/CHANGES.rst
index a979e8411e5b..213fb1a7df80 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,6 +2,27 @@
Changes
=======
+**2017-05-19**
+
+*Released 6.0.0*
+
+- Add support for Bot API 2.3.1
+- Add support for ``deleteMessage`` API method
+- New, simpler API for ``JobQueue`` - https://github.com/python-telegram-bot/python-telegram-bot/pull/484
+- Download files into file-like objects - https://github.com/python-telegram-bot/python-telegram-bot/pull/459
+- Use vendor ``urllib3`` to address issues with timeouts
+ - The default timeout for messages is now 5 seconds. For sending media, the default timeout is now 20 seconds.
+- String attributes that are not set are now ``None`` by default, instead of empty strings
+- Add ``text_markdown`` and ``text_html`` properties to ``Message`` - https://github.com/python-telegram-bot/python-telegram-bot/pull/507
+- Add support for Socks5 proxy - https://github.com/python-telegram-bot/python-telegram-bot/pull/518
+- Add support for filters in ``CommandHandler`` - https://github.com/python-telegram-bot/python-telegram-bot/pull/536
+- Add the ability to invert (not) filters - https://github.com/python-telegram-bot/python-telegram-bot/pull/552
+- Add ``Filters.group`` and ``Filters.private``
+- Compatibility with GAE via ``urllib3.contrib`` package - https://github.com/python-telegram-bot/python-telegram-bot/pull/583
+- Add equality rich comparision operators to telegram objects - https://github.com/python-telegram-bot/python-telegram-bot/pull/604
+- Several bugfixes and other improvements
+- Remove some deprecated code
+
**2017-04-17**
*Released 5.3.1*
diff --git a/PKGBUILD b/PKGBUILD
index a0941ff4342e..85850c9e29f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
-pkgver=5.3.1.r1451.e2a651a
-_pkgver=5.3.1
+pkgver=6.0.0
+_pkgver=6.0.0
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')
@@ -22,7 +22,8 @@ prepare() {
pkgver() {
cd "$srcdir/$pkgname"
- printf "%s.r%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ # printf "%s.r%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s" "$(git describe --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {