summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12017-05-24 22:22:17 +0500
committerevgfilim12017-05-24 22:22:17 +0500
commited2efc552534128b37abd927e08a32af56554385 (patch)
treea2421e9cb1ced834d85c45ce70d1283d9a04f9ee
parentdaa0d43419ec68a61aee7d54da7c647f9452869a (diff)
downloadaur-ed2efc552534128b37abd927e08a32af56554385.tar.gz
Temporary fix for error in `build()`
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff289a6164f0..39859cd2eaec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
pkgver = 6.0.1.r3.ff897ce
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/python-telegram-bot/python-telegram-bot
changelog = CHANGES.rst
arch = any
@@ -13,7 +13,9 @@ pkgbase = python-telegram-bot-git
provides = python-telegram-bot
conflicts = python-telegram-bot
source = python-telegram-bot-git::git+https://github.com/python-telegram-bot/python-telegram-bot.git
+ source = https://gist.githubusercontent.com/evgfilim1/95ba7f195d742136831321ca4419a058/raw/0baefa28fe0ca34b6d1d6716514d3adcea8e98a7/setup.py.patch
sha256sums = SKIP
+ sha256sums = d6adcf6e70d632ee20263be3e902ef4a400cc31c16bfb2f49bb6e0aaccf35066
pkgname = python-telegram-bot-git
diff --git a/PKGBUILD b/PKGBUILD
index 0cd6fea69c24..daf12bcc4862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-telegram-bot-git')
pkgver=6.0.1.r3.ff897ce
_pkgver=6.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')
url="https://github.com/${pkgname%-git}/${pkgname%-git}"
@@ -12,12 +12,15 @@ makedepends=('git' 'python-setuptools')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
changelog='CHANGES.rst'
-source=("${pkgname}::git+${url}.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+${url}.git"
+ 'https://gist.githubusercontent.com/evgfilim1/95ba7f195d742136831321ca4419a058/raw/0baefa28fe0ca34b6d1d6716514d3adcea8e98a7/setup.py.patch')
+sha256sums=('SKIP'
+ 'd6adcf6e70d632ee20263be3e902ef4a400cc31c16bfb2f49bb6e0aaccf35066')
prepare() {
cd "$srcdir/$pkgname"
git submodule update --init --recursive
+ patch setup.py ../setup.py.patch
}
pkgver() {