summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12017-07-26 11:17:35 +0500
committerevgfilim12017-07-26 11:17:35 +0500
commited9a5b1113b6debc9cbe7afa6cf78a08e6ad5cfa (patch)
tree13d3f8bad5a2bb5e75d810de886260868c71f060
parent10a1ef4b5b9a718e16097db5be899194bb035f5d (diff)
downloadaur-ed9a5b1113b6debc9cbe7afa6cf78a08e6ad5cfa.tar.gz
Updated to version 7.0.0.r1
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGES.rst25
-rw-r--r--PKGBUILD2
3 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6545094f17c..dc9c2ece4d78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telegram-bot-git
pkgdesc = A Python wrapper around the Telegram Bot API
- pkgver = 6.1.0.r77.81987c3
+ pkgver = 7.0.0.r1.2aae602
pkgrel = 1
url = https://github.com/python-telegram-bot/python-telegram-bot
changelog = CHANGES.rst
diff --git a/CHANGES.rst b/CHANGES.rst
index 46df7be55876..1f31da170800 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,17 +2,24 @@
Changes
=======
-**DATE TBD**
-*WIP 6.2.0*
-- Improved filters for user_id/username/chat.
+**2017-07-25**
+*Released 7.0.0*
+
+- Fully support Bot API 3.2.
+- New filters for handling messages from specific chat/user id (PR #677).
+- Add the possibility to add objects as arguments to send_* methods (PR #742).
+- Fixed download of URLs with UTF-8 chars in path (PR #688).
+- Fixed URL parsing for ``Message`` text properties (PR #689).
+- Fixed args dispatching in ``MessageQueue``'s decorator (PR #705).
+- Fixed regression preventing IPv6 only hosts from connnecting to Telegram servers (Issue #720).
+- ConvesationHandler - check if a user exist before using it (PR #699).
+- Removed deprecated ``telegram.Emoji``.
+- Removed deprecated ``Botan`` import from ``utils`` (``Botan`` is still available through ``contrib``).
+- Removed deprecated ``ReplyKeyboardHide``.
+- Removed deprecated ``edit_message`` argument of ``bot.set_game_score``.
- Internal restructure of files.
+- Improved documentation.
- Improved unitests.
-- Fully support Bot API 3.2
-- Modified docstrings
-- Remove deprecated ``telegram.Emoji``.
-- Remove deprecated ``Botan`` import from ``utils`` (``Botan`` is still available through ``contrib``).
-- Remove deprecated ``ReplyKeyboardHide``.
-- Remove deprecated ``edit_message`` argument of `bot.set_game_score``.
**2017-06-18**
diff --git a/PKGBUILD b/PKGBUILD
index e5f9494aa4be..f6c609ea4f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname=('python-telegram-bot-git')
-pkgver=6.1.0.r77.81987c3
+pkgver=7.0.0.r1.2aae602
pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
arch=('any')