summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail f. Shiryaev2023-10-09 15:02:32 +0200
committerMikhail f. Shiryaev2023-10-09 15:02:32 +0200
commitdfb6a2f28cea4d6c43cb060e01d465f69ac46c86 (patch)
tree13e62cb9110519700ba2f7d8c80208b9473d9d74
parentf7c2250fb6c1b27e5115fc784d8c759a6403b0b2 (diff)
downloadaur-dfb6a2f28cea4d6c43cb060e01d465f69ac46c86.tar.gz
Update to the working version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8539ca9816fa..d528f1d5083e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-telegram-send
pkgdesc = Send messages and files over Telegram from the command-line
- pkgver = 0.34
- pkgrel = 2
+ pkgver = 0.37
+ pkgrel = 1
url = https://github.com/rahiel/telegram-send
arch = any
license = GPL3
@@ -12,9 +12,7 @@ pkgbase = python-telegram-send
depends = python-telegram-bot
depends = python-colorama
depends = python-appdirs
- source = https://pypi.org/packages/source/t/telegram-send/telegram-send-0.34.tar.gz
- source = MAX_MESSAGE_LENGTH.patch::https://github.com/rahiel/telegram-send/pull/117.patch
- sha512sums = 9d9ed3db7950d68700686dc79cdd7e84547c50d5dabca2f007dba5de72c6e3f54562f252ff6ddebc1a390dbb84aec54b9c5e8fe770ce8aa2a894c194ea9c8904
- sha512sums = 7d33dedfc870e5f5c31500362da3cd252800a5a667336155948557ea1887c2e92c583a39c1232e135f879ac9cd6a080eaabda702e9b461daf7f2cd6beb7eb408
+ source = https://pypi.org/packages/source/t/telegram-send/telegram-send-0.37.tar.gz
+ sha256sums = 9f69abb331598e4b6ba8a173b15df7dfdec4eec17e3600a43d554c53b0150695
pkgname = python-telegram-send
diff --git a/PKGBUILD b/PKGBUILD
index 98915446e87f..301cb29efb72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,18 @@
_base=telegram-send
pkgname=python-${_base}
pkgdesc="Send messages and files over Telegram from the command-line"
-pkgver=0.34
-pkgrel=2
+pkgver=0.37
+pkgrel=1
arch=(any)
url="https://github.com/rahiel/${_base}"
license=(GPL3)
depends=(python-telegram-bot python-colorama python-appdirs)
makedepends=(python-build python-installer python-setuptools python-wheel)
-source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz
- MAX_MESSAGE_LENGTH.patch::${url}/pull/117.patch)
-sha512sums=('9d9ed3db7950d68700686dc79cdd7e84547c50d5dabca2f007dba5de72c6e3f54562f252ff6ddebc1a390dbb84aec54b9c5e8fe770ce8aa2a894c194ea9c8904'
- '7d33dedfc870e5f5c31500362da3cd252800a5a667336155948557ea1887c2e92c583a39c1232e135f879ac9cd6a080eaabda702e9b461daf7f2cd6beb7eb408')
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha256sums=(
+ '9f69abb331598e4b6ba8a173b15df7dfdec4eec17e3600a43d554c53b0150695'
+)
-prepare() {
- cd ${_base}-${pkgver}
- # https://github.com/rahiel/telegram-send/issues/115
- patch -p1 -i ../MAX_MESSAGE_LENGTH.patch
-}
build() {
cd ${_base}-${pkgver}