summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-01-17 09:30:56 -0500
committerCarlos Aznarán Laos2023-01-17 09:30:56 -0500
commitf7c2250fb6c1b27e5115fc784d8c759a6403b0b2 (patch)
treebb62315e080ec466d5688cf8ac61f432b5758776
parent68e386db4850b2faf846de3390ca01e9b95d7128 (diff)
downloadaur-f7c2250fb6c1b27e5115fc784d8c759a6403b0b2.tar.gz
Add patch in order to be compatible with python-telegram-bot v20 or later
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 38 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b17382d7b7e5..8539ca9816fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python-telegram-send
- pkgdesc = Send messages and files over Telegram from the command-line.
+ pkgdesc = Send messages and files over Telegram from the command-line
pkgver = 0.34
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rahiel/telegram-send
arch = any
- license = GPLv3
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-telegram-bot
depends = python-colorama
depends = python-appdirs
- depends = python-cryptography
- source = https://files.pythonhosted.org/packages/92/8c/0ef8546d52cfc5bfb942033cb8e1064cf14e6b1c754196229cda5ecaf8a4/telegram-send-0.34.tar.gz
- b2sums = c0f7b5ec5e28c57e9b93627ea8cc6f62800b060ffe2725fa558bef71d2646e7b00900f30b5ab02b63b329bdb61622d46e0d3441e36d7676a5b8f5c9b73d813eb
+ source = https://pypi.org/packages/source/t/telegram-send/telegram-send-0.34.tar.gz
+ source = MAX_MESSAGE_LENGTH.patch::https://github.com/rahiel/telegram-send/pull/117.patch
+ sha512sums = 9d9ed3db7950d68700686dc79cdd7e84547c50d5dabca2f007dba5de72c6e3f54562f252ff6ddebc1a390dbb84aec54b9c5e8fe770ce8aa2a894c194ea9c8904
+ sha512sums = 7d33dedfc870e5f5c31500362da3cd252800a5a667336155948557ea1887c2e92c583a39c1232e135f879ac9cd6a080eaabda702e9b461daf7f2cd6beb7eb408
pkgname = python-telegram-send
diff --git a/PKGBUILD b/PKGBUILD
index 15d482d89394..98915446e87f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,34 @@
-# Maintainer: Michael Duell <dev _at_ akurei _._ me>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Michael Duell <dev _at_ akurei _._ me>
# Contributor: Jian Zeng <anonymousknight96 at gmail dot com>
-
-pkgname=python-telegram-send
-_name=telegram-send
+_base=telegram-send
+pkgname=python-${_base}
+pkgdesc="Send messages and files over Telegram from the command-line"
pkgver=0.34
-pkgrel=1
-pkgdesc="Send messages and files over Telegram from the command-line."
+pkgrel=2
arch=(any)
-url='https://github.com/rahiel/telegram-send'
-license=('GPLv3')
-makedepends=('python-setuptools')
-depends=('python-telegram-bot' 'python-colorama' 'python-appdirs' 'python-cryptography')
-source=("https://files.pythonhosted.org/packages/92/8c/0ef8546d52cfc5bfb942033cb8e1064cf14e6b1c754196229cda5ecaf8a4/telegram-send-0.34.tar.gz")
+url="https://github.com/rahiel/${_base}"
+license=(GPL3)
+depends=(python-telegram-bot python-colorama python-appdirs)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz
+ MAX_MESSAGE_LENGTH.patch::${url}/pull/117.patch)
+sha512sums=('9d9ed3db7950d68700686dc79cdd7e84547c50d5dabca2f007dba5de72c6e3f54562f252ff6ddebc1a390dbb84aec54b9c5e8fe770ce8aa2a894c194ea9c8904'
+ '7d33dedfc870e5f5c31500362da3cd252800a5a667336155948557ea1887c2e92c583a39c1232e135f879ac9cd6a080eaabda702e9b461daf7f2cd6beb7eb408')
+
+prepare() {
+ cd ${_base}-${pkgver}
+ # https://github.com/rahiel/telegram-send/issues/115
+ patch -p1 -i ../MAX_MESSAGE_LENGTH.patch
+}
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" -O1
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-b2sums=('c0f7b5ec5e28c57e9b93627ea8cc6f62800b060ffe2725fa558bef71d2646e7b00900f30b5ab02b63b329bdb61622d46e0d3441e36d7676a5b8f5c9b73d813eb')