summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-02-21 10:29:23 +0800
committerlilac2020-02-21 10:29:23 +0800
commit04907fe8ecc0fc7cace459982c9dedf27c81f555 (patch)
treef05b26a6ab3a55e39472df5df2405aefc18540e2
parenta62fb5f1fa4f5be2273e974bcb2b6744ae7be25f (diff)
downloadaur-04907fe8ecc0fc7cace459982c9dedf27c81f555.tar.gz
update by lilac
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9166c69145c..b347361d2822 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.10.10
- pkgrel = 3
+ pkgver = 1.11.0
+ pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
license = MIT
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.10.10.tar.gz
- sha256sums = 126b392db57b83526e18779b7c6f4011789c2dd02377f64004afd0e0ce29a37e
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.11.0.tar.gz
+ sha256sums = 9d13512038f62b0fba266a510b500e57d4cfe8013ce9a7b613725ab7de96321a
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 142b123209e8..cf56f5026e6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.10.10
-pkgrel=3
+pkgver=1.11.0
+pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
url="https://github.com/LonamiWebs/Telethon"
license=(MIT)
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('126b392db57b83526e18779b7c6f4011789c2dd02377f64004afd0e0ce29a37e')
+sha256sums=('9d13512038f62b0fba266a510b500e57d4cfe8013ce9a7b613725ab7de96321a')
build() {
cd "$srcdir/$_name-$pkgver"
@@ -21,6 +20,9 @@ package() {
cd "$srcdir/$_name-$pkgver"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
+ # make sure we don't install annoying files
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "$pkgdir/$_site_packages/tests/"
+}