summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-10-22 18:41:34 +0800
committerlilac2020-10-22 18:41:34 +0800
commit0feaf651834f04d3750cf6c2a291772759bb51c4 (patch)
tree0018f494fe02892f4b5465aa7a42f0a38c1ec582
parent71ae5ae92c35845f4b29ba4f2e14830ae3bf8526 (diff)
downloadaur-0feaf651834f04d3750cf6c2a291772759bb51c4.tar.gz
[lilac] updated to 1.17.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d351d078bc3..f8faf0e004ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.17.0
+ pkgver = 1.17.1
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.17.0.tar.gz
- sha256sums = dd38dd46dfd023cfdf9158f0b730c181ebff89a3b78408e7301552b543b62b92
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.17.1.tar.gz
+ sha256sums = 2d5f29ee0f0ea835ecc81407b8cd540760cbaabdead177f2891fff06eb234ff0
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 152f1f835da7..ccca671c0581 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.17.0
+pkgver=1.17.1
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.17.0.tar.gz")
-sha256sums=('dd38dd46dfd023cfdf9158f0b730c181ebff89a3b78408e7301552b543b62b92')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.17.1.tar.gz")
+sha256sums=('2d5f29ee0f0ea835ecc81407b8cd540760cbaabdead177f2891fff06eb234ff0')
build() {
- cd "$srcdir/Telethon-1.17.0"
+ cd "$srcdir/Telethon-1.17.1"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.17.0"
+ cd "$srcdir/Telethon-1.17.1"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"