summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-07-29 03:36:50 +0800
committerlilac2020-07-29 03:36:50 +0800
commit1a40ab35e03380d17288c6c008f5ed9e7c77c42e (patch)
tree275cb849f9f0f715430da692d65316c96fc82507
parentd30d4ae466d01df764ca3999ce13467dd5c73d78 (diff)
downloadaur-1a40ab35e03380d17288c6c008f5ed9e7c77c42e.tar.gz
[lilac] updated to 1.16.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10b7be061053..443e1fe8a90d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.15.0
+ pkgver = 1.16.0
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.15.0.tar.gz
- sha256sums = 3f4c1496353365100baf932736e537def0cff4eaf67b85944fb329b87c4be361
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.16.0.tar.gz
+ sha256sums = 3c4a431b065c0950415c0764c559d0ad81eaf043d5fb6d14402020db8f6dd75e
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index c8980dc3230b..f26c30e6751b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.15.0
+pkgver=1.16.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.15.0.tar.gz")
-sha256sums=('3f4c1496353365100baf932736e537def0cff4eaf67b85944fb329b87c4be361')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.16.0.tar.gz")
+sha256sums=('3c4a431b065c0950415c0764c559d0ad81eaf043d5fb6d14402020db8f6dd75e')
build() {
- cd "$srcdir/Telethon-1.15.0"
+ cd "$srcdir/Telethon-1.16.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.15.0"
+ cd "$srcdir/Telethon-1.16.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"