summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-07-10 05:54:26 +0800
committerlilac2021-07-10 05:54:26 +0800
commit403ec8ed0fe19782abb6ca42b61d3371a3034459 (patch)
tree7076c2b709a8ed23c30279df11df181a3d5dee25
parentcb30b10309981059c14813b7826572dde83a415c (diff)
downloadaur-403ec8ed0fe19782abb6ca42b61d3371a3034459.tar.gz
[lilac] updated to 1.23.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820067f57aeb..f49309b3d139 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.22.0
+ pkgver = 1.23.0
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.22.0.tar.gz
- sha256sums = d2b619f8e0bf852876991ffdcac8142bca6e42e2be4b4e7012dd4d1f5f098c69
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.23.0.tar.gz
+ sha256sums = ba7551ce447e954aad67f3eeba4bab7574cca07a2c6f41e5be69904e6e0ec313
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 8ea9eaf6a388..06e82a4bc3f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.22.0
+pkgver=1.23.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.22.0.tar.gz")
-sha256sums=('d2b619f8e0bf852876991ffdcac8142bca6e42e2be4b4e7012dd4d1f5f098c69')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.23.0.tar.gz")
+sha256sums=('ba7551ce447e954aad67f3eeba4bab7574cca07a2c6f41e5be69904e6e0ec313')
build() {
- cd "$srcdir/Telethon-1.22.0"
+ cd "$srcdir/Telethon-1.23.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.22.0"
+ cd "$srcdir/Telethon-1.23.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files