summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-01-22 17:41:26 +0800
committerlilac2019-01-22 17:41:26 +0800
commit44c7f8f76978ef5b4c2ebc4141fb9110e5b00714 (patch)
treebc2e8b2a4e592ed9b9a35ca7187e327ff686d4be
parent0cc5b5ee293e9c26da5f589bbd367a3643a36774 (diff)
downloadaur-44c7f8f76978ef5b4c2ebc4141fb9110e5b00714.tar.gz
update by lilac
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80c628f3bae8..76e5487c4b12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.3
+ pkgver = 1.5.4
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,9 +8,10 @@ pkgbase = python-telethon
depends = python
depends = python-pyaes
depends = python-rsa
+ depends = python-async_generator
depends = python-setuptools
- source = https://files.pythonhosted.org/packages/86/b0/af48e7b0530bef9f88f7c8f4bd1f4f4b421f587268358191839cff792bf3/Telethon-1.3.tar.gz
- md5sums = fe1e8f0c911f2beb681b28d44c2be23a
+ source = https://files.pythonhosted.org/packages/source/t/telethon/Telethon-1.5.4.tar.gz
+ md5sums = 1d4f3ef17b0a398be4d35a7f8599c9ac
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 47fe2efaf1dc..95278a79be56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
_pkgname=Telethon
pkgname=python-telethon
-pkgver=1.3
+pkgver=1.5.4
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=('any')
url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
-depends=('python' 'python-pyaes' 'python-rsa' 'python-setuptools')
-source=('https://files.pythonhosted.org/packages/86/b0/af48e7b0530bef9f88f7c8f4bd1f4f4b421f587268358191839cff792bf3/Telethon-1.3.tar.gz')
-md5sums=('fe1e8f0c911f2beb681b28d44c2be23a')
+depends=('python' 'python-pyaes' 'python-rsa' 'python-async_generator' 'python-setuptools')
+_name=${pkgname#python-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('1d4f3ef17b0a398be4d35a7f8599c9ac')
build() {
cd "$srcdir/$_pkgname-$pkgver"