summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-03-16 23:18:55 +0800
committerlilac2021-03-16 23:18:55 +0800
commit5ce8250fb53e8ca4cc46b2218712f2a3afe77397 (patch)
tree0c2f80c688f027c5589b51f17c5c50b7086a9d13
parentef54287563dadd7d8f23453e2f002375c5bd91a3 (diff)
downloadaur-5ce8250fb53e8ca4cc46b2218712f2a3afe77397.tar.gz
[lilac] updated to 1.21.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e87300f6bfdb..40ff5cad0e6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.21
+ pkgver = 1.21.1
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.21.tar.gz
- sha256sums = 8ce569183ea0824133c263b6ea3ae98224608fd319a2ada4f98387e31a3ee51a
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.21.1.tar.gz
+ sha256sums = 993c837ef745addf972a27d7bfba0ce518a2863d1a50e0737255b764d23e0ef2
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 13efdc47de39..42132c549829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.21
+pkgver=1.21.1
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.21.tar.gz")
-sha256sums=('8ce569183ea0824133c263b6ea3ae98224608fd319a2ada4f98387e31a3ee51a')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.21.1.tar.gz")
+sha256sums=('993c837ef745addf972a27d7bfba0ce518a2863d1a50e0737255b764d23e0ef2')
build() {
- cd "$srcdir/Telethon-1.21"
+ cd "$srcdir/Telethon-1.21.1"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.21"
+ cd "$srcdir/Telethon-1.21.1"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files