summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-10-29 18:53:36 +0800
committerlilac2020-10-29 18:53:36 +0800
commit6ba8855fd5fe350e412dbb3d0db7c185b993ac96 (patch)
tree20e4218f7ee453de71c6ff7c74215b0b20a0ba51
parentec14371d381ee37e8abffb867491cdb784ae2b5d (diff)
downloadaur-6ba8855fd5fe350e412dbb3d0db7c185b993ac96.tar.gz
[lilac] updated to 1.17.5-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0aee77f57b90..263b57d9c95c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.17.4
+ pkgver = 1.17.5
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.17.4.tar.gz
- sha256sums = edba701f63187d12707f09303dbd0f2515864bb7326c330a18adde12ef4ea635
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.17.5.tar.gz
+ sha256sums = 958432bb3849d3e1fecfb45e211832a579fb4340a1d2b21b0d1a7d30407e39ec
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 32f78fd469f0..64ad3cfa394d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.17.4
+pkgver=1.17.5
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,18 +8,17 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.17.4.tar.gz")
-sha256sums=('edba701f63187d12707f09303dbd0f2515864bb7326c330a18adde12ef4ea635')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.17.5.tar.gz")
+sha256sums=('958432bb3849d3e1fecfb45e211832a579fb4340a1d2b21b0d1a7d30407e39ec')
build() {
- cd "$srcdir/Telethon-1.17.4"
+ cd "$srcdir/Telethon-1.17.5"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.17.4"
+ cd "$srcdir/Telethon-1.17.5"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# make sure we don't install annoying files
local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")