summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2024-05-14 10:24:01 +0800
committerlilac2024-05-14 10:24:01 +0800
commit847d47cdc30817d7dad84cd053395cd7ebcde54d (patch)
tree1827fd1f023cc437427520666d0b4054ed782bfc
parentd15876584fefe6a9b7491dd22627e6f1b3e18b2e (diff)
downloadaur-847d47cdc30817d7dad84cd053395cd7ebcde54d.tar.gz
[lilac] updated to 1.35.0-3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a1041b2ea79..db1368768311 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,21 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
pkgver = 1.35.0
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/LonamiWebs/Telethon
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-pyaes
depends = python-rsa
+ optdepends = python-cryptg: alternative crypto library
+ optdepends = python-pysocks: socks proxy support
+ optdepends = python-python-socks: socks proxy support
+ optdepends = python-hachoir: parse media metadata for uploading
+ optdepends = python-pillow: resize photos for uploading
source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.35.0.tar.gz
sha256sums = 99d7a2e161e9af1cdf03feef7a3fea6eef304a9caf620fe13aefc53099845555
diff --git a/PKGBUILD b/PKGBUILD
index 8244b545bc40..62b7a378c178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
_name=Telethon
pkgname=python-telethon
pkgver=1.35.0
-pkgrel=1
+pkgrel=3
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+optdepends=('python-cryptg: alternative crypto library' 'python-pysocks: socks proxy support' 'python-python-socks: socks proxy support' 'python-hachoir: parse media metadata for uploading' 'python-pillow: resize photos for uploading')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.35.0.tar.gz")
sha256sums=('99d7a2e161e9af1cdf03feef7a3fea6eef304a9caf620fe13aefc53099845555')
build() {
cd "$srcdir/Telethon-1.35.0"
- python3 setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/Telethon-1.35.0"
- python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# make sure we don't install any world-writable or root-readable-only files
# we shouldn't need to fix ownership as we extract tarballs as a non-root user