summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-09-27 20:22:22 +0800
committerlilac2022-09-27 20:22:22 +0800
commit8cb455fdf8a202f038d00ec0b5d102441095f1af (patch)
tree2373f61638a2495d6630b1549963c60b865d5e6c
parentdbac8550208099feb3ca10314ac39450be4905a8 (diff)
downloadaur-8cb455fdf8a202f038d00ec0b5d102441095f1af.tar.gz
[lilac] updated to 1.25.2-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a41b249f2b1f..abec7c85a000 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.25.1
+ pkgver = 1.25.2
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.25.1.tar.gz
- sha256sums = 06edc1852ae0eacef6f598b96638cf1fbd30e505bd314268ff762eaf3c1d550f
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.25.2.tar.gz
+ sha256sums = a63da7a456727ffb0cac6b385563e57c4863d2b64fff58f9fa28ce188142b238
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 60dd6d863203..56fb6a47e252 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.25.1
+pkgver=1.25.2
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.25.1.tar.gz")
-sha256sums=('06edc1852ae0eacef6f598b96638cf1fbd30e505bd314268ff762eaf3c1d550f')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.25.2.tar.gz")
+sha256sums=('a63da7a456727ffb0cac6b385563e57c4863d2b64fff58f9fa28ce188142b238')
build() {
- cd "$srcdir/Telethon-1.25.1"
+ cd "$srcdir/Telethon-1.25.2"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.25.1"
+ cd "$srcdir/Telethon-1.25.2"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files