summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-04-15 05:45:18 +0800
committerlilac2023-04-15 05:45:18 +0800
commit8fb6d31f844576cc42fe2a076ef859903b4d7d82 (patch)
treeaea8934683723733911bc871cbfa8b8e2e6b61d0
parenta5fa2ed3989295653b2f2bb72ebd85065ac95958 (diff)
downloadaur-8fb6d31f844576cc42fe2a076ef859903b4d7d82.tar.gz
[lilac] updated to 1.28.5-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 707f4ff3327d..0cbcacf34d0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.28.2
+ pkgver = 1.28.5
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.28.2.tar.gz
- sha256sums = 893c10f133974fba4c53eb1736b6514d596d1cd94c83436a711f3345df945199
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.28.5.tar.gz
+ sha256sums = b3990ec22351a3f3e1af376729c985025bbdd3bdabdde8c156112c3d3dfe1941
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index d57d3313e532..d32873d4ca47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.28.2
+pkgver=1.28.5
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.28.2.tar.gz")
-sha256sums=('893c10f133974fba4c53eb1736b6514d596d1cd94c83436a711f3345df945199')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.28.5.tar.gz")
+sha256sums=('b3990ec22351a3f3e1af376729c985025bbdd3bdabdde8c156112c3d3dfe1941')
build() {
- cd "$srcdir/Telethon-1.28.2"
+ cd "$srcdir/Telethon-1.28.5"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.28.2"
+ cd "$srcdir/Telethon-1.28.5"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files