summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-08-30 21:06:07 +0800
committerlilac2022-08-30 21:06:07 +0800
commita50abc9e897a8bffb288da73dc21bebd1207cdf5 (patch)
tree5e858c4d3fa139c46b83a85e12317a60fbec44b0
parent28968825e5be9990510d29f3ce9628335f129fd6 (diff)
downloadaur-a50abc9e897a8bffb288da73dc21bebd1207cdf5.tar.gz
[lilac] updated to 1.25.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 178211b3e997..6ce23ad67105 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.24.0
+ pkgver = 1.25.0
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.24.0.tar.gz
- sha256sums = 818cb61281ed3f75ba4da9b68cb69486bed9474d2db4e0aa16e482053117452c
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.25.0.tar.gz
+ sha256sums = 676d97b926e6d30dbed31d6c6e6611cdec9fc82759785cea55c4770b74614290
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 3e098caa01a1..c7a84b983a9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.24.0
+pkgver=1.25.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.24.0.tar.gz")
-sha256sums=('818cb61281ed3f75ba4da9b68cb69486bed9474d2db4e0aa16e482053117452c')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.25.0.tar.gz")
+sha256sums=('676d97b926e6d30dbed31d6c6e6611cdec9fc82759785cea55c4770b74614290')
build() {
- cd "$srcdir/Telethon-1.24.0"
+ cd "$srcdir/Telethon-1.25.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.24.0"
+ cd "$srcdir/Telethon-1.25.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files