summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-02-28 06:13:31 +0800
committerlilac2021-02-28 06:13:31 +0800
commitab5bc40e197fb19af827943896b18493c51dd2ce (patch)
treee1d93551ae25a57c962e89017241d33261738548
parentc39a70259cc0a4e4f3547c088989f269d4e26b71 (diff)
downloadaur-ab5bc40e197fb19af827943896b18493c51dd2ce.tar.gz
[lilac] updated to 1.20-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09c826803a29..2dd4f9b14d90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.19.5
+ pkgver = 1.20
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.19.5.tar.gz
- sha256sums = 680aad5e532639e90e781ff905aea30dd038e8f7c0fb73ae1c7e58fd3f503808
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.20.tar.gz
+ sha256sums = 41fea16755897c91a2d1a90b4c6d178dad06746650230c3adf5d7fb2e285f1d3
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 84d0550b5362..6d1d745618f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.19.5
+pkgver=1.20
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.19.5.tar.gz")
-sha256sums=('680aad5e532639e90e781ff905aea30dd038e8f7c0fb73ae1c7e58fd3f503808')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.20.tar.gz")
+sha256sums=('41fea16755897c91a2d1a90b4c6d178dad06746650230c3adf5d7fb2e285f1d3')
build() {
- cd "$srcdir/Telethon-1.19.5"
+ cd "$srcdir/Telethon-1.20"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.19.5"
+ cd "$srcdir/Telethon-1.20"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files