summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-08-19 04:57:27 +0800
committerlilac2023-08-19 04:57:27 +0800
commitbf6b554a2974f778eba1570bc008b95e37f89be5 (patch)
tree3e9cbad55dda6122ae1a789acace9a5ca84cb09c
parent9aded234a879da3d7aa44c711bb43da67d1cf847 (diff)
downloadaur-bf6b554a2974f778eba1570bc008b95e37f89be5.tar.gz
[lilac] updated to 1.29.3-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77ca6749c698..0cda6b127271 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.29.2
+ pkgver = 1.29.3
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.29.2.tar.gz
- sha256sums = c34885c9435864fbd5e379700b7c022571c2b6b6c5dc9beb5ceac5699aa96c4a
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.29.3.tar.gz
+ sha256sums = cac3091ab61bdd2286bdfb72fb3ab7cc86a9e8d3327ff8fec56d215e05009e1e
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 41c65a8b1384..b371af1192b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.29.2
+pkgver=1.29.3
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.29.2.tar.gz")
-sha256sums=('c34885c9435864fbd5e379700b7c022571c2b6b6c5dc9beb5ceac5699aa96c4a')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.29.3.tar.gz")
+sha256sums=('cac3091ab61bdd2286bdfb72fb3ab7cc86a9e8d3327ff8fec56d215e05009e1e')
build() {
- cd "$srcdir/Telethon-1.29.2"
+ cd "$srcdir/Telethon-1.29.3"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.29.2"
+ cd "$srcdir/Telethon-1.29.3"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files