summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-06-20 04:42:49 +0800
committerlilac2021-06-20 04:42:49 +0800
commitcb30b10309981059c14813b7826572dde83a415c (patch)
tree57d8cca680ee6d837e701e8c934f992d430bb50c
parent5ce8250fb53e8ca4cc46b2218712f2a3afe77397 (diff)
downloadaur-cb30b10309981059c14813b7826572dde83a415c.tar.gz
[lilac] updated to 1.22.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40ff5cad0e6d..820067f57aeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.21.1
+ pkgver = 1.22.0
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.21.1.tar.gz
- sha256sums = 993c837ef745addf972a27d7bfba0ce518a2863d1a50e0737255b764d23e0ef2
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.22.0.tar.gz
+ sha256sums = d2b619f8e0bf852876991ffdcac8142bca6e42e2be4b4e7012dd4d1f5f098c69
pkgname = python-telethon
-
diff --git a/PKGBUILD b/PKGBUILD
index 42132c549829..8ea9eaf6a388 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.21.1
+pkgver=1.22.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.21.1.tar.gz")
-sha256sums=('993c837ef745addf972a27d7bfba0ce518a2863d1a50e0737255b764d23e0ef2')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.22.0.tar.gz")
+sha256sums=('d2b619f8e0bf852876991ffdcac8142bca6e42e2be4b4e7012dd4d1f5f098c69')
build() {
- cd "$srcdir/Telethon-1.21.1"
+ cd "$srcdir/Telethon-1.22.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.21.1"
+ cd "$srcdir/Telethon-1.22.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files