summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-08-25 02:29:52 +0800
committerlilac2020-08-25 02:29:52 +0800
commitcb491eaa8b62fe6ea78ec68f133c3e795be7b894 (patch)
tree63b0fe29604fef201b467ed8cbe9b6b6e3b0b7a2
parent8b623c8c05f8b30f96df670be231ee2b0aec4d5f (diff)
downloadaur-cb491eaa8b62fe6ea78ec68f133c3e795be7b894.tar.gz
[lilac] updated to 1.16.4-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8f2f8117a06..3df6c909f15d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.16.1
+ pkgver = 1.16.4
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.16.1.tar.gz
- sha256sums = 2a22e8acebab788e7cb668df7259cd8c4605a3dde3292b20e97545db99f55e57
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.16.4.tar.gz
+ sha256sums = f0ce68e0431f9f08d356e369d235a640e1d9feaf5b21ca7db0a97b149a181d1d
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 567334f0eaec..29591db248e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.16.1
+pkgver=1.16.4
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.16.1.tar.gz")
-sha256sums=('2a22e8acebab788e7cb668df7259cd8c4605a3dde3292b20e97545db99f55e57')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.16.4.tar.gz")
+sha256sums=('f0ce68e0431f9f08d356e369d235a640e1d9feaf5b21ca7db0a97b149a181d1d')
build() {
- cd "$srcdir/Telethon-1.16.1"
+ cd "$srcdir/Telethon-1.16.4"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.16.1"
+ cd "$srcdir/Telethon-1.16.4"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"