summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-07-05 05:59:54 +0800
committerlilac2020-07-05 05:59:54 +0800
commitd30d4ae466d01df764ca3999ce13467dd5c73d78 (patch)
tree13ddc914f5420633bc5af21a5790bf59a908a0e5
parent0a3dfb60dd2a1dcf4101f8a72dbf9f00085b5f2b (diff)
downloadaur-d30d4ae466d01df764ca3999ce13467dd5c73d78.tar.gz
[lilac] updated to 1.15.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4c34ac241cb..10b7be061053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.14.0
+ pkgver = 1.15.0
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.14.0.tar.gz
- sha256sums = d8bb37f80c4a8befa92d0525f00a578a74064645e48d7aa0cc4731f3d813e1b9
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.15.0.tar.gz
+ sha256sums = 3f4c1496353365100baf932736e537def0cff4eaf67b85944fb329b87c4be361
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 3849da393bf9..c8980dc3230b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.14.0
+pkgver=1.15.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.14.0.tar.gz")
-sha256sums=('d8bb37f80c4a8befa92d0525f00a578a74064645e48d7aa0cc4731f3d813e1b9')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.15.0.tar.gz")
+sha256sums=('3f4c1496353365100baf932736e537def0cff4eaf67b85944fb329b87c4be361')
build() {
- cd "$srcdir/Telethon-1.14.0"
+ cd "$srcdir/Telethon-1.15.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.14.0"
+ cd "$srcdir/Telethon-1.15.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"