summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-03-15 00:09:12 +0800
committerlilac2021-03-15 00:09:12 +0800
commitef54287563dadd7d8f23453e2f002375c5bd91a3 (patch)
treeab02d94964a2137ecbade597624d529f4c3d9fec
parentab5bc40e197fb19af827943896b18493c51dd2ce (diff)
downloadaur-ef54287563dadd7d8f23453e2f002375c5bd91a3.tar.gz
[lilac] updated to 1.21-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dd4f9b14d90..e87300f6bfdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.20
+ pkgver = 1.21
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.20.tar.gz
- sha256sums = 41fea16755897c91a2d1a90b4c6d178dad06746650230c3adf5d7fb2e285f1d3
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.21.tar.gz
+ sha256sums = 8ce569183ea0824133c263b6ea3ae98224608fd319a2ada4f98387e31a3ee51a
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 6d1d745618f3..13efdc47de39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.20
+pkgver=1.21
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.20.tar.gz")
-sha256sums=('41fea16755897c91a2d1a90b4c6d178dad06746650230c3adf5d7fb2e285f1d3')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.21.tar.gz")
+sha256sums=('8ce569183ea0824133c263b6ea3ae98224608fd319a2ada4f98387e31a3ee51a')
build() {
- cd "$srcdir/Telethon-1.20"
+ cd "$srcdir/Telethon-1.21"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.20"
+ cd "$srcdir/Telethon-1.21"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files