summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-04-07 05:11:20 +0800
committerlilac2023-04-07 05:11:20 +0800
commitfda89434b7f5f1229575d72bfbfc149d5feb2ec2 (patch)
tree6b29bdb1cd54c74153676116b63a7e64ba279bb8
parentb526e44ccae3accb75c8ddacd762d05d6678a30c (diff)
downloadaur-fda89434b7f5f1229575d72bfbfc149d5feb2ec2.tar.gz
[lilac] updated to 1.28.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 202d70cc3487..e94cd401dda3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.27.0
+ pkgver = 1.28.1
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.27.0.tar.gz
- sha256sums = 21fb26051adc521a4a00a157e6f4a9e87711940ac3504414f96e66056918ef61
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.28.1.tar.gz
+ sha256sums = efcbbe864558fc64913d107659768120875c83bdc5d355b6e5531a04a9b84616
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index f3cbf7e1534a..cee77ac0288e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.27.0
+pkgver=1.28.1
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.27.0.tar.gz")
-sha256sums=('21fb26051adc521a4a00a157e6f4a9e87711940ac3504414f96e66056918ef61')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.28.1.tar.gz")
+sha256sums=('efcbbe864558fc64913d107659768120875c83bdc5d355b6e5531a04a9b84616')
build() {
- cd "$srcdir/Telethon-1.27.0"
+ cd "$srcdir/Telethon-1.28.1"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.27.0"
+ cd "$srcdir/Telethon-1.28.1"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files