summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-10 23:22:04 -0600
committerLuis Martinez2022-01-10 23:22:04 -0600
commit36db0c88855ff25475a4e1e796be06c242bc376c (patch)
tree9d7d29f9a33701c7cb8ac87af6f243445d8269ce
parent0501ee4fc7deafb8d08c5a0bab667b5b1caa3477 (diff)
downloadaur-36db0c88855ff25475a4e1e796be06c242bc376c.tar.gz
package cleanup
* changed source URL to a more readable one * add PYTHONHASHSEED for reproducible builds * changed arch to 'any' since this package doesn't use any compiled extensions
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcc9cc471e58..b23429ffafd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-teletype
- pkgdesc = A high-level cross platform Python tty library
+ pkgdesc = Cross-platform Python tty library
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jkwill87/teletype
- arch = x86_64
+ arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = python-teletype-1.1.0.tar.gz::https://files.pythonhosted.org/packages/05/4d/19c0f8e928ee75ddd324de66ef1c7fac23dd0fa60f9d5f6b2686da9e24e0/teletype-1.1.0.tar.gz
+ source = python-teletype-1.1.0.tar.gz::https://files.pythonhosted.org/packages/source/t/teletype/teletype-1.1.0.tar.gz
sha256sums = 3e3c770bbcb9abe5f1ad3dbfee1a386e6e385a541c062e0d96141ed72a06af0a
pkgname = python-teletype
-
diff --git a/PKGBUILD b/PKGBUILD
index 4193fa498991..e2d93ba5ccef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=python-teletype
pkgver=1.1.0
-pkgrel=1
-pkgdesc='A high-level cross platform Python tty library'
-arch=('x86_64')
+pkgrel=2
+pkgdesc='Cross-platform Python tty library'
+arch=('any')
url='https://github.com/jkwill87/teletype'
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/05/4d/19c0f8e928ee75ddd324de66ef1c7fac23dd0fa60f9d5f6b2686da9e24e0/teletype-1.1.0.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/teletype/teletype-$pkgver.tar.gz")
sha256sums=('3e3c770bbcb9abe5f1ad3dbfee1a386e6e385a541c062e0d96141ed72a06af0a')
build() {
- cd "teletype-${pkgver}"
+ cd "teletype-$pkgver"
python setup.py build
}
package() {
- cd "teletype-${pkgver}"
+ export PYTHONHASHSEED=0
+ cd "teletype-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 *.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 readme.md -t "$pkgdir/usr/share/doc/$pkgname/README.md"
}
+
# vim:set ts=2 sw=2 et: