summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Holthuis2015-06-21 19:42:28 +0200
committerJan Holthuis2015-06-21 19:42:28 +0200
commitd15f59a2574ceb4e6313359b5e08e2af42e6142a (patch)
treed9d448dc7839959e812f68999f180816324822e8
downloadaur-d15f59a2574ceb4e6313359b5e08e2af42e6142a.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
3 files changed, 56 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..dae8f3f5ea32
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = python-tempmail
+ pkgdesc = Wrapper for online service which provides temporary email address: https://temp-mail.ru/
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/saippuakauppias/temp-mail
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ optdepends = python-simplejson: For a serious speed boost in JSON decode
+ provides = python-tempmail
+ source = https://pypi.python.org/packages/source/t/temp-mail/temp-mail-0.2.tar.gz
+
+pkgname = python-tempmail
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95edab4a52fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-tempmail
+ pkgdesc = Wrapper for online service which provides temporary email address: https://temp-mail.ru/
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/saippuakauppias/temp-mail
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ optdepends = python-simplejson: For a serious speed boost in JSON decode
+ provides = python-tempmail
+ source = https://pypi.python.org/packages/source/t/temp-mail/temp-mail-0.2.tar.gz
+ md5sums = f625c6b699769cd83b133fdc8d5bec92
+
+pkgname = python-tempmail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e56dabfbf34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jan Holthuis <holthuis.jan@googlemail.com>
+
+pkgname=python-tempmail
+_pypiname=temp-mail
+pkgver=0.2
+pkgrel=1
+pkgdesc="Wrapper for online service which provides temporary email address: https://temp-mail.ru/"
+arch=('any')
+url="https://github.com/saippuakauppias/temp-mail"
+license=('MIT')
+depends=('python'
+ 'python-requests')
+makedepends=('python-setuptools')
+optdepends=('python-simplejson: For a serious speed boost in JSON decode')
+conflics=('python-tempmail-git')
+provides=('python-tempmail')
+source=("https://pypi.python.org/packages/source/t/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('f625c6b699769cd83b133fdc8d5bec92')
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file