summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-06-16 19:29:35 +0200
committerMichel Zou2020-06-16 19:29:35 +0200
commitc3e00a96004d8c35b745ecde0898c68d29d4cb83 (patch)
treedeecdceaaa68279cb5fe6647f2279de9f679fd02
downloadaur-c3e00a96004d8c35b745ecde0898c68d29d4cb83.tar.gz
1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d89c527fd0f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-tensap
+ pkgdesc = A Python package for the approximation of functions and tensors
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/anthony-nouy/tensap
+ arch = any
+ license = LGPL
+ makedepends = python-setuptools
+ depends = python-scipy
+ source = https://github.com/anthony-nouy/tensap/archive/v1.0.tar.gz
+ sha256sums = e0828ad9b2a330d996b2ce4a445980dd7bc22e79573abb7b36ff0920779b8a9d
+
+pkgname = python-tensap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a758985cc84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=python-tensap
+pkgver=1.0
+pkgrel=1
+pkgdesc="A Python package for the approximation of functions and tensors"
+url="https://github.com/anthony-nouy/tensap"
+arch=(any)
+license=('LGPL')
+makedepends=('python-setuptools')
+depends=('python-scipy')
+source=("https://github.com/anthony-nouy/tensap/archive/v${pkgver}.tar.gz")
+sha256sums=('e0828ad9b2a330d996b2ce4a445980dd7bc22e79573abb7b36ff0920779b8a9d')
+
+prepare() {
+ cd "${srcdir}"/tensap-$pkgver
+ curl -L https://github.com/anthony-nouy/tensap/commit/a5d26f4de04f2868f03d5a7932ca64d9d127c93a.patch | patch -p1 || echo "ok"
+}
+
+build() {
+ cd "${srcdir}"/tensap-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/tensap-$pkgver"
+ python setup.py install --root=${pkgdir} --optimize=1
+}
+
+