summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroysstu2019-02-20 15:59:52 +0100
committeroysstu2019-02-20 15:59:52 +0100
commit82555297825e5d716cdcb362497494cd4bde8063 (patch)
tree1fa9a297caf51aad740191928612838d913d817d
downloadaur-82555297825e5d716cdcb362497494cd4bde8063.tar.gz
v0.5.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b0d4244288c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-tensorflow-probability
+ pkgdesc = Probabilistic reasoning and statistical analysis in TensorFlow
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/tensorflow/probability
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python-tensorflow
+ depends = python-numpy
+ depends = python-six
+ source = https://github.com/tensorflow/probability/archive/v0.5.0.tar.gz
+ sha256sums = 6e0e21b40555cbc1725f2fde96fa7705c160d856ae67f84107ad889896314694
+
+pkgname = python-tensorflow-probability
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ef3573fcb23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Oystein Sture <oysstu (at) gmail (dot) com>
+# Contributor:
+pkgname=python-tensorflow-probability
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Probabilistic reasoning and statistical analysis in TensorFlow"
+url="https://github.com/tensorflow/probability"
+arch=('any')
+license=('APACHE')
+depends=('python-tensorflow' 'python-numpy' 'python-six')
+makedepends=('python-setuptools')
+source=("https://github.com/tensorflow/probability/archive/v${pkgver}.tar.gz")
+sha256sums=('6e0e21b40555cbc1725f2fde96fa7705c160d856ae67f84107ad889896314694')
+
+build() {
+ cd "${srcdir}"/probability-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}"/probability-$pkgver
+ python setup.py install --root=${pkgdir} --optimize=1
+}