summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylon Edwards2018-04-28 21:54:29 -0700
committerDylon Edwards2018-04-28 21:54:29 -0700
commit4749a4855e81c0a5bcf04e1815eee6df55911f61 (patch)
treeb88314f8e777550be90164723d5d1fac7442f285
downloadaur-4749a4855e81c0a5bcf04e1815eee6df55911f61.tar.gz
Imports version 0.3.0
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD91
-rw-r--r--python-tensorly.changelog2
4 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..149ef04ffb93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = python-tensorly
+ pkgdesc = Simple and Fast Tensor Learning in Python
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = http://tensorly.org/stable/home.html
+ changelog = python-tensorly.changelog
+ arch = x86_64
+ license = BSD
+ checkdepends = python-pytest
+ checkdepends = python2-pytest
+ depends = python
+ depends = python2
+ optdepends = mxnet
+ optdepends = python-numpy
+ optdepends = python2-numpy
+ optdepends = python-pytorch
+ optdepends = python-pytorch-cuda
+ optdepends = python2-pytorch
+ optdepends = python2-pytorch-cuda
+ source = tensorly-0.3.0.tar.gz::https://github.com/tensorly/tensorly/archive/0.3.0.tar.gz
+ md5sums = d2bb823c87246b4ff45a175f984beb3d
+
+pkgname = python-tensorly
+ depends = python
+ optdepends = mxnet
+ optdepends = python-numpy
+ optdepends = python-pytorch
+ optdepends = python-pytorch-cuda
+
+pkgname = python2-tensorly
+ depends = python2
+ optdepends = python2-numpy
+ optdepends = python2-pytorch
+ optdepends = python2-pytorch-cuda
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b568e813bcb4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Blacklist everything by default to avoid accidentally committing something
+*
+
+# Whitelist the following files and directories
+!/*.changelog
+!/.SRCINFO
+!/.gitignore
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..061c15ad7516
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,91 @@
+# -*- mode: shell-script -*-
+# Maintainer: Dylon Edwards <deltaecho at archlinux dot us>
+
+pkgbase='python-tensorly'
+pkgname=(
+ python{,2}-tensorly
+)
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Simple and Fast Tensor Learning in Python"
+arch=('x86_64')
+url="http://tensorly.org/stable/home.html"
+license=('BSD')
+depends=(
+ python{,2}
+)
+checkdepends=(
+ python{,2}-pytest
+)
+optdepends=(
+ mxnet
+ python{,2}-numpy
+ python{,2}-pytorch{,-cuda}
+)
+changelog="${pkgbase}.changelog"
+source=("tensorly-${pkgver}.tar.gz::https://github.com/tensorly/tensorly/archive/${pkgver}.tar.gz")
+md5sums=('d2bb823c87246b4ff45a175f984beb3d')
+
+function check() {
+ cd "tensorly-${pkgver}"
+
+ # ------- #
+ # Python3 #
+ # ------- #
+
+ if pacman -Qsq '^python-numpy$' &>/dev/null; then
+ echo "Testing against the numpy backend for Python3 ..."
+ TENSORLY_BACKEND='numpy' pytest -v tensorly
+ fi
+
+ if pacman -Qsq '^python-pytorch(-cuda)?$' &>/dev/null; then
+ echo "Testing against the pytorch backend for Python3 ..."
+ TENSORLY_BACKEND='pytorch' pytest -v tensorly
+ fi
+
+ if pacman -Qsq '^mxnet$' &>/dev/null; then
+ echo "Testing against the mxnet backend for Python3 ..."
+ TENSORLY_BACKEND='mxnet' pytest -v tensorly
+ fi
+
+ # ------- #
+ # Python2 #
+ # ------- #
+
+ if pacman -Qsq '^python2-numpy$' &>/dev/null; then
+ echo "Testing against the numpy backend for Python2 ..."
+ TENSORLY_BACKEND='numpy' pytest2 -v tensorly
+ fi
+
+ if pacman -Qsq '^python2-pytorch(-cuda)?$' &>/dev/null; then
+ echo "Testing against the pytorch backend for Python2 ..."
+ TENSORLY_BACKEND='pytorch' pytest2 -v tensorly
+ fi
+}
+
+function package_python-tensorly() {
+ depends=(
+ python
+ )
+ optdepends=(
+ mxnet
+ python-numpy
+ python-pytorch{,-cuda}
+ )
+
+ cd "tensorly-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+}
+
+function package_python2-tensorly() {
+ depends=(
+ python2
+ )
+ optdepends=(
+ python2-numpy
+ python2-pytorch{,-cuda}
+ )
+
+ cd "tensorly-${pkgver}"
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+}
diff --git a/python-tensorly.changelog b/python-tensorly.changelog
new file mode 100644
index 000000000000..227a1be58a03
--- /dev/null
+++ b/python-tensorly.changelog
@@ -0,0 +1,2 @@
+2018-04-28 Dylon Edwards <deltaecho at archlinux dot us>
+ * python-tensorly 0.3.0