summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoprobelm2024-03-11 08:57:32 -0400
committernoprobelm2024-03-11 08:57:32 -0400
commit9aa58db28998bd5b046fa1311e9f712f7278491c (patch)
treece2390be2ee01cb16f0e15b63c26047c0cee8557
parent42e2f4b38e0187ba477b6b8e48d1f2efd6476330 (diff)
downloadaur-9aa58db28998bd5b046fa1311e9f712f7278491c.tar.gz
Added poetry-core.patch to address issue with upstream build-backend configuration
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--poetry-core.patch41
3 files changed, 50 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3741d8fdb25a..df4e53662ede 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,9 @@ pkgbase = python-terminaltables
depends = python
source = terminaltables-3.1.10.tar.gz::https://github.com/matthewdeanmartin/terminaltables/archive/v3.1.10.tar.gz
source = python-3.8.patch
+ source = poetry-core.patch
sha512sums = 84fa403cee4206b6b19de0206d89535bd2965a0796e1890dd9b0a9c6593c5f41d0d24b88ee9db426067c777712a4e810d67d4d0246496239a7a96b53a24e8174
sha512sums = 9a33ef51cbd2854bf9acc247e2d966332229446158e7dae9cad25e03335eb9689d50b0a22234285aa56c707e6e93c12f950299efcfbe7e42ed527216090592f2
+ sha512sums = 4497c99e4bf54709944aff2296460728259750b6b81db549d0b06f31cd853106124c264e51f30a4b3da4e74ea662baa6f39ec48f1d58b59701fbe3e43469a543
pkgname = python-terminaltables
diff --git a/PKGBUILD b/PKGBUILD
index a82926a1fe50..5a154d05af69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,18 +12,22 @@ depends=('python')
makedepends=('python-build' 'python-wheel' 'python-installer' 'python-poetry-core')
checkdepends=('python-pytest' 'python-colorama' 'python-termcolor' 'python-colorclass')
source=("${_pyname}-${pkgver}.tar.gz::https://github.com/matthewdeanmartin/${_pyname}/archive/v${pkgver}.tar.gz"
- python-3.8.patch)
+ python-3.8.patch
+ poetry-core.patch)
sha512sums=('84fa403cee4206b6b19de0206d89535bd2965a0796e1890dd9b0a9c6593c5f41d0d24b88ee9db426067c777712a4e810d67d4d0246496239a7a96b53a24e8174'
- '9a33ef51cbd2854bf9acc247e2d966332229446158e7dae9cad25e03335eb9689d50b0a22234285aa56c707e6e93c12f950299efcfbe7e42ed527216090592f2')
+ '9a33ef51cbd2854bf9acc247e2d966332229446158e7dae9cad25e03335eb9689d50b0a22234285aa56c707e6e93c12f950299efcfbe7e42ed527216090592f2'
+ '4497c99e4bf54709944aff2296460728259750b6b81db549d0b06f31cd853106124c264e51f30a4b3da4e74ea662baa6f39ec48f1d58b59701fbe3e43469a543')
prepare() {
cd ${_pyname}-${pkgver}
patch -Np1 < ../python-3.8.patch
+ patch -Np1 < ../poetry-core.patch
+
}
build() {
cd ${_pyname}-${pkgver}
- python -m build --wheel --no-isolation --skip-dependency-check
+ python -m build --wheel --no-isolation
}
package() {
diff --git a/poetry-core.patch b/poetry-core.patch
new file mode 100644
index 000000000000..eca231beb792
--- /dev/null
+++ b/poetry-core.patch
@@ -0,0 +1,41 @@
+From 9e3dda0efb54fee6934c744a13a7336d24c6e9e9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 27 Jan 2022 10:33:08 +0100
+Subject: [PATCH] Switch build-backend to poetry-core
+
+poetry-core is the lightweight counterpart of poetry that is intended
+to be used as a build-backend. Unlike poetry, it does not require
+installing all the dependencies of the package manager, making
+the builds much faster. The generated artifacts are the same.
+---
+ pyproject-whl.toml | 4 ++--
+ pyproject.toml | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/pyproject-whl.toml b/pyproject-whl.toml
+index 3c186b7..7242e38 100644
+--- a/pyproject-whl.toml
++++ b/pyproject-whl.toml
+@@ -62,5 +62,5 @@ python = ">=2.6 || >=3.0"
+ pytest = "==6.0.1"
+
+ [build-system]
+-requires = ["poetry>=0.12"]
+-build-backend = "poetry.masonry.api"
++requires = ["poetry>=1.0.0"]
++build-backend = "poetry.core.masonry.api"
+diff --git a/pyproject.toml b/pyproject.toml
+index bdcd0ce..bf5518c 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -62,5 +62,5 @@ python = ">=2.6 || >=3.0"
+ pytest = "==6.0.1"
+
+ [build-system]
+-requires = ["poetry>=0.12"]
+-build-backend = "poetry.masonry.api"
++requires = ["poetry-core>=1.0.0"]
++build-backend = "poetry.core.masonry.api"
+--
+2.44.0
+