summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArne Beer2015-12-02 13:11:02 +0100
committerArne Beer2015-12-02 13:11:02 +0100
commit24253be9b0520be80667931f21723b5814506ac6 (patch)
tree38d131b64f9a4980d7e6a04831355e17ed962952
downloadaur-24253be9b0520be80667931f21723b5814506ac6.tar.gz
Version 2.1.0 initial
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccec0ec63dd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = terminaltables-git
+ pkgdesc = Generate simple tables in terminals from a nested list of strings.
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/Robpol86/terminaltables
+ arch = any
+ license = MIT
+ makedepends = git python-setuptools
+ provides = terminaltables
+ source = git+https://github.com/Robpol86/terminaltables.git
+ sha256sums = SKIP
+
+pkgname = terminaltables-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..652751072d4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+terminaltables/
+terminaltables-git-0.3.6-1-any.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ba526c4980d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Arne Beer <arne@twobeer.de>
+
+_gitname=terminaltables
+pkgname=${_gitname}-git
+pkgver=2.1.0
+pkgrel=1
+arch=('any')
+pkgdesc='Generate simple tables in terminals from a nested list of strings.'
+license=('MIT')
+makedepends=('git python-setuptools')
+provides=('terminaltables')
+url='https://github.com/Robpol86/terminaltables'
+source=("git+https://github.com/Robpol86/terminaltables.git")
+sha256sums=('SKIP')
+
+package() {
+ cd "${_gitname}"
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ # Install
+ python setup.py install --optimize=1 --root="${pkgdir}"
+
+ # Install License
+ # MIT/X11 license
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}