summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-07-06 23:16:18 +0800
committerPumpkinCheshire2021-07-06 23:16:18 +0800
commit841f9355ecda849a0b55ee15d70403f06b0cce15 (patch)
tree08f411cd3975543a87172746cf0de0c309200dbe
parentf912192004915598713dddb1d4d92b3e36d9033d (diff)
downloadaur-841f9355ecda849a0b55ee15d70403f06b0cce15.tar.gz
bump to 0.3.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87359d2daeed..0a3a3fc63b8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-termplotlib
pkgdesc = Plotting on the command line
- pkgver = 0.3.5
+ pkgver = 0.3.7
pkgrel = 1
url = https://github.com/nschloe/termplotlib
arch = any
license = GPL
- makedepends = python
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/t/termplotlib/termplotlib-0.3.5.tar.gz
- sha256sums = d99d6620a945ed377a4d54c34855c816b54de0e7ba5d6816c2a620abdef46b6d
+ depends = python
+ depends = python-numpy
+ depends = gnuplot
+ source = https://files.pythonhosted.org/packages/source/t/termplotlib/termplotlib-0.3.7.tar.gz
+ b2sums = 409b2c0eabb3a476fdf0e3641722a6786daabc7f7270fcf7703e5b7c62ce5230d8591ca348e49d5accaee74ff388042a79b52155cf7710a8c5b29e01a7247456
pkgname = python-termplotlib
diff --git a/PKGBUILD b/PKGBUILD
index c8e72bf6806e..4ee1824d6234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: PumpkinCheshire <sollyonzou at gmail dot com>
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
pkgname=python-termplotlib
_name=termplotlib
-pkgver=0.3.5
+pkgver=0.3.7
pkgrel=1
pkgdesc="Plotting on the command line"
arch=('any')
url="https://github.com/nschloe/termplotlib"
license=('GPL')
-makedepends=('python'
- 'python-setuptools')
+depends=('python' 'python-numpy' 'gnuplot')
+makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('d99d6620a945ed377a4d54c34855c816b54de0e7ba5d6816c2a620abdef46b6d')
+b2sums=('409b2c0eabb3a476fdf0e3641722a6786daabc7f7270fcf7703e5b7c62ce5230d8591ca348e49d5accaee74ff388042a79b52155cf7710a8c5b29e01a7247456')
build() {
cd "$srcdir/$_name-$pkgver"
+ export PYTHONHASHSEED=0
python -c "from setuptools import setup; setup()" build
}