summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-11-27 23:10:19 +0000
committerGrey Christoforo2018-11-27 23:10:19 +0000
commit76313eb555bf33e72dfb54b78363c8a08b34c01a (patch)
tree8a0ea6d079a804a5948ec7382bebe8bbcdfec48d
downloadaur-76313eb555bf33e72dfb54b78363c8a08b34c01a.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4076926d518
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-tesserocr
+ pkgdesc = A simple, Pillow-friendly, Python wrapper around tesseract-ocr API using Cython
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://github.com/sirfz/tesserocr
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/t/tesserocr/tesserocr-2.3.1.tar.gz
+ md5sums = 99e2001affe861ae3a5aa2e9f233e2d7
+
+pkgname = python-tesserocr
+ depends = python
+
+pkgname = python2-tesserocr
+ depends = python2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93f5d9f2777e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c0f9188eafe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgbase=python-tesserocr
+pkgname=('python-tesserocr' 'python2-tesserocr')
+_module='tesserocr'
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="A simple, Pillow-friendly, Python wrapper around tesseract-ocr API using Cython"
+url="https://github.com/sirfz/tesserocr"
+depends=()
+makedepends=('python-setuptools' 'python2-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/t/tesserocr/tesserocr-${pkgver}.tar.gz")
+md5sums=('99e2001affe861ae3a5aa2e9f233e2d7')
+
+prepare() {
+ cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
+}
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python-tesserocr() {
+ depends+=('python')
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+package_python2-tesserocr() {
+ depends+=('python2')
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}