summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-15 22:28:27 +0100
committerNarrat2020-01-15 22:28:27 +0100
commit419bb8f5a8b1354fa70a4912b5fc232b4c12ac1e (patch)
tree695ea0dde863b8a61d7fb2d48ea7ada72f66bc36
parentf5847ee5875bfc8d3f22e8411e3b12dd8127d6cd (diff)
downloadaur-419bb8f5a8b1354fa70a4912b5fc232b4c12ac1e.tar.gz
Update to 4.0.0, which dropped Python2 support
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 11 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f6b5b14ed30..7e26fe5f1165 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-testinfra
pkgdesc = Testinfra test your infrastructures
- pkgver = 3.4.0
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/philpep/testinfra
arch = any
@@ -9,15 +9,9 @@ pkgbase = python-testinfra
makedepends = python-setuptools
makedepends = python-pbr
makedepends = python-sphinx
- makedepends = python2
- makedepends = python2-setuptools
- makedepends = python2-pbr
- source = git+https://github.com/philpep/testinfra.git#tag=3.4.0
+ depends = python-six
+ source = git+https://github.com/philpep/testinfra.git#tag=4.0.0
sha256sums = SKIP
pkgname = python-testinfra
- depends = python-six
-
-pkgname = python2-testinfra
- depends = python2-six
diff --git a/PKGBUILD b/PKGBUILD
index e84af32938d2..821a2e5d878b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,34 @@
+# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: gardar <aur@gardar.net>
# Contributor: Morten Linderud <morten@linderud.pw>
pkgbase="python-testinfra"
-pkgname=("python-testinfra" "python2-testinfra")
+pkgname="python-testinfra"
_pkgname='testinfra'
-pkgver=3.4.0
+pkgver=4.0.0
pkgrel=1
pkgdesc='Testinfra test your infrastructures'
url='https://github.com/philpep/testinfra'
arch=('any')
license=('Apache')
-makedepends=('python' 'python-setuptools' 'python-pbr' 'python-sphinx'
- 'python2' 'python2-setuptools' 'python2-pbr')
+depends=('python-six')
+makedepends=('python' 'python-setuptools' 'python-pbr' 'python-sphinx')
source=("git+https://github.com/philpep/testinfra.git#tag=$pkgver")
sha256sums=('SKIP')
-prepare() {
- cp -a ${_pkgname}{,-py2}
-}
-
build() {
- #export PBR_VERSION=$pkgver
-
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
python setup.py build
make -C doc html man
-
- cd "${srcdir}/${_pkgname}-py2"
- python2 setup.py build
- make -C doc html man
}
-package_python-testinfra() {
- depends=('python-six')
-
- cd "${srcdir}/${_pkgname}"
- #export PBR_VERSION=$pkgver
+package() {
+ cd "${_pkgname}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -d "${pkgdir}/usr/share/doc/${pkgname}"
cp -r doc/build/html/* "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm 644 doc/build/man/testinfra.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
}
-package_python2-testinfra() {
- depends=('python2-six')
-
- cd "${srcdir}/${_pkgname}-py2"
- #export PBR_VERSION=$pkgver
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -d "${pkgdir}/usr/share/doc/${pkgname}"
- cp -r doc/build/html/* "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dm 644 doc/build/man/testinfra.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
-}
# vim:set ft=sh ts=2 sw=2 et: